-
        

Ergebnis 1 bis 5 von 5

Thema: Problem mit Atmel Starter Kit

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    03.06.2004
    Ort
    Düsseldorf
    Alter
    33
    Beiträge
    158

    Problem mit Atmel Starter Kit

    Anzeige

    Hallo,

    ich habe ein bzw. mehrere Probleme mit meinem Starter Kit STK500. Das Board ist nahezu ungebraucht und etwa ein Jahr alt. Ich habe es bei Reichelt neu gekauft und erste Tests mit dem auf dem Board befindlichen Programm waren erfolgreich. Danach habe ich mit dem Board etwa ein Jahr nichts mehr gemacht.

    Als ich heute einen ATTiny11L programmieren wollte, habe ich es schon nicht geschafft eine Verbindung mit AVR Studio 3.56 zum Controller herzustellen. Die Verbindungen müssten alle richtig eingestellt worden sein. Also die Jumper stimmten und die Verbindungen habe ich so gemacht, wie in der Anleitung beschrieben (serial High Voltage). Der Controller war richtig rum hereingesteckt.

    Danach habe ich den Controller wieder entfernt und den 8515 reingesteckt. Ich habe das ISP Kabel an den roten Sockel angeschlossen und die Flachbandkabel für Switches und LEDs. Ich wollte also die ursprüngliche Version wieder haben. Auch diesmal konnte ich keine Verbindung mit dem Studio herstellen.

    Mit Verbindung meine ich folgendes: Ich versuche ein Erease durchzuführen. Ich stelle beim 8515 die Programmierung auf ISP und beim Tiny11 stand sie auf Highvoltage. In der Status Box stand "Detecting ... Failed".

    Ich benutze WinXP Home mit einem USB->RS232 Converter. Eigentlich funktioniert der mit anderen seriellen Bausteinen/Boards sehr gut.

    Woran könnte es liegen? Kann mir jemand vielleicht Fotos geben, wo die genau Beschaltung für 8515 und Tiny11 gezeigt wird?

    Danke und Gruß,

    Stefan

    EDIT:

    Ich habe vorsichtshalber mal ein Foto vom Anschluss beigelegt.
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken bild_019.jpg  

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Hast du vor einem Jahr auch mit dem USB-Seriell Converter gearbeitet. Es gibt immer wieder Beiträge über Probleme in Zusammenhang mit Programmieren.

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    03.06.2004
    Ort
    Düsseldorf
    Alter
    33
    Beiträge
    158
    Hallo,

    vorweg: da ich einen Laptop ohne seriellen Anschluss habe, habe ich schon letztes Jahr mit dem USB Wandler gearbeitet habe. Er funktioniert auch wunderbar mit anderen Boards.

    Jedenfalls funktioniert das Übertragen eines Programms mit dem AVR Studio 4.0 nach einem Firmware Update. Den 8515 kann ich problemlos programmieren. Beim ATTiny11 muss ich ATTiny12 einstellen. Sonst macht er Probleme. Naja funktioniert jedenfalls. Da ich bald mit dem ATTiny15 arbeite, kann ich doch direkt ISP nehmen, dann muss ich nicht mehr mit Hochvolt Programmieren, oder?

    Gruß,

    Stefan
    http://www.tappertzhofen.eu/bpp2

    Basic++ Programmiersprache
    für den C-Control I Mikrocontroller

  4. #4
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Gut wenns funktioniert. Wenn ISP geht dann verwende ich nur das. Immer ins STK stecken ist doch umständlich.
    Hubert

  5. #5
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    30.07.2005
    Beiträge
    569
    Zitat Zitat von Hubert.G
    Gut wenns funktioniert. Wenn ISP geht dann verwende ich nur das. Immer ins STK stecken ist doch umständlich.
    Hubert
    Das funktioniert übrigens Problemlos.
    Die Käfer stecken bei mir nur dann im STK, wenn noch keine Platine fertig ist oder Hardware Fehler weitestgehend ausgeschlossen werden sollen.
    Grundregeln des Forenpostings:
    1. Nutze niemals die Suchfunktion!
    2. Überprüfe niemals die Topics nach Ähnlichkeiten!
    3. Schreibe alles in hellgelb!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •