-         

Ergebnis 1 bis 2 von 2

Thema: RN-MEGA8Plus: V extern messen funzt nicht (Board-V schon)

  1. #1

    RN-MEGA8Plus: V extern messen funzt nicht (Board-V schon)

    Anzeige

    Hallo,

    ich möchte eine externe Spannungsquelle messen, z.B. Batterie.

    Das Board hängt an einem 9V Netzteil. Also habe ich EXREF
    vom Board (5V) und einen externen Spannungsteiler mit Schleifer an
    ADC0.

    Der ADC-Wert schwankt dann völlig wahrlos irgendwo zwischen
    0-1023 hin und her, bis ich entweder das eine Kabel am Spannungs-
    teiler auf GRD 5V oder an GRD des Netzteiles lege. Dann ist ADC = 0.
    Wenn ich nun mit dem anderen Kabel auf PLUS des Netzteiles oder
    auf 5V Plus am Board gehe, misst der ADC korrekt und zuverlässig.

    Wie kann das sein? Wenn ich den Spannungsteiler offen lasse oder
    z.B. eine Batterie anschliesse, läuft der ADC einfach hin und her.
    Kann das mit EXREF zusammenhängen? Muss ich in dem Fall eine
    interne REF nehmen? Ich kann mir das überhaupt nicht erklären.
    Der ADC bekommt doch überhaupt keinen Saft, wenn am Spannungs-
    teiler nichts anliegt!? Kann das damit zusammenhängen, dass ich
    den Spannunsteiler mit <1000 Ohm Widerständen gemacht habe?

    Ich danke Euch für Eure Tipps, bin noch absoluter Anfänger.


    Otten.

  2. #2
    Hat sich erledigt.

    Batteriespannung MINUS bzw. Spannungsteiler zusätzlich an GRD des
    Boards/Netzteils.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •