-
        
+ Antworten
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Relais an einem Port

  1. #1
    Torsten
    Gast

    Relais an einem Port

    Hallo,
    wollte ein Relais direkt am Port anschließen, aber trotz hochohmiger Spule scheint der Strom am Ausgangsport wohl zu schwach. Wie kann ich Relais nun ein ansteuern?

    Grüße
    Torsten

  2. #2
    Gast
    Hallo Torsten,

    Du brauchst eine Transistorstufe damit kannst Du dann jedes normale Relais schalten. In der Regel sieht die so aus:



    Es gibt aber noch ne etwas weniger oft benutzte ALternative mit PNP Transistor. Diese hat den Vorteils das das Relais dann anzieht, wenn der Port auf 0 geschaltet wird. Beim Einschalten sind ja die Ports immer auf log. 1 !



    Gruß Frank

  3. #3
    Gast
    Hallo Torsten,

    es geht sogar noch einfacher. Nimm einen Inverter 4011, dann brauchst Du nur das IC einlöten bzw. dessen Fassung. Geht schneller und fehlerfreier.

    Gutes Gelingen
    Rainer

  4. #4
    Gast
    Zitat Zitat von Anonymous
    Beim Einschalten sind ja die Ports immer auf log. 1 !
    Was werden denn Hier für Märchen verzapft??? Bei welchem Controller soll das denn sein? Hab noch nie nen Controller in den Händen gehalten bei dem nach dem Einschalten die Ports auf Ausgang und HIGH waren. Oder ist das bei der CC so? Na dann gut Nacht

  5. #5
    Gast
    Lass den Pullup an der Basis weg, dann schaltet das Relais auch nicht während sich der Controller initialisiert. Die Ports sind nach einem Power-On als Eingänge definiert und der Pull-Up sorgt dafür, dass das Relais anzieht.

    Der Pullup wird höchstens gebraucht, wenn es ein Open Collektor-Ausgang ist.

  6. #6
    Gast
    Ich bin bei der Relaisschaltung von einer C-Control ausgegangen. Hier sind standardmäßig PullUp Widerstände vorhanden. Daher ist die zweite Schaltung günstiger! Mag bei anderen Prozessoren anders sein, das muß halt schon jeder selbst wissen. Daher hab ich ja beide Schaltungen gepostet.

    Gruß Frank

  7. #7
    1hdsquad
    Gast
    aus protest schreibe ich hier was hin

  8. #8
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    07.12.2005
    Ort
    Euskirchen-Großbüllesheim
    Alter
    66
    Beiträge
    2.063
    Nach dem Einschalten oder während / nach Reset sind alle Pins auf Eingang geschaltet und hochohmig mit Tendenz nach High. Bei internen PullUp's sind sie "richtig" High. Bis ein angehender Ausgang durch die Initialisierung erst mal zum Ausgang wird, ist dieser Pin vorübergehend ein "Ausgang im High-Zustand".
    MfG Karl-Heinz
    HobbyElektronik hier klicken ....

  9. #9
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    11.09.2004
    Ort
    Düsseldorf
    Beiträge
    3.948
    @Kalledom


    Schau mal aufs Datum.
    Das Topic was 1hdsquad da ausgegraben hat ist schon seit über 2 Jahren erledigt.
    Gruß
    Ratber

  10. #10
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    07.12.2005
    Ort
    Euskirchen-Großbüllesheim
    Alter
    66
    Beiträge
    2.063
    Sorry, ich hatte nur 1hdsquad's Datum von gestern und bei den anderen 14.11.???? gesehen.
    MfG Karl-Heinz
    HobbyElektronik hier klicken ....

+ Antworten
Seite 1 von 2 12 LetzteLetzte

Benutzer, die dieses Thema gelesen haben: 0

Derzeit gibt es keine Benutzer zum Anzeigen.

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •