-         

Ergebnis 1 bis 5 von 5

Thema: leds mit uln2803ag an 12 v

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    05.10.2006
    Ort
    Saarbrücken
    Beiträge
    13

    leds mit uln2803ag an 12 v

    Anzeige

    Hallo zusammen
    Ich bin hier seit Tagen an Verzeifeln und ich hoffe jemand von euch kann mir helfen.

    Vorab:
    JA ich habe gegoogle .. und JA .. ich hab auch die SUFU schon bis zum Erbrechen bemüht,
    aber trotzdem komme ich nicht weiter ..

    Ich möchte per ATMEL Mega32 mehrere LEDS ansteueren. Das ganze soll über einen ULN2803AG betrieben werden, weil die Ausgänge vom Mega32 ja bekanntlich nur 20 bzw. 40 mA vertragen ..

    Deshalb hab vorn paar Tagen bei Conrad hier in unserer Stadt 2 ULN2803A erworben.
    Erhalten habe ich aber 2 ULN2803AG von Toshiba .. (also noch G am Ende dazu). Datenblätter zu diesen konnte ich leider überhaupt keine im Netz finden, aber ich gehen einfach mal davon aus, dass die Pinbelegung die Gleiche sein müsste, wie bei dem ohne G

    An den LEDs soll eine Spannung von 12 V anliegen .. ( näturlich hab ich die passenden Widerstände berechnet und vorgeschaltet)

    Nachdem ich jetzt so ziemlich jeden Beitrag in diesem und in anderen Forum gelesen habe, in dem es um den ULN2803A ging, hab ich das ganze so geschalten

    Code:
    Mega32 Ausgang mit 5 V -> Pin 1 (IN 1)      
    GND des 12V Netzteils -> Pin 9
    + des 12V Netzteils -> LED mit Widerstand 
    Led mit Widerstand ->  Pin 16 (OUT 1)
    Pin 10 brauch man ja bei LED nicht, weil keine Induktivität

    Nur leider passiert nix.

    Wenn ich das ganze aber so schalte, d.h. über die Stormversorgung vom uC, gehts komischerweise

    Code:
    Mega32 Ausgang mit 5 V -> Pin 1 (IN 1)      
    GND des Mega32 Ports  -> Pin 9
    + des Mega32 Ports -> -> LED mit Widerstand
    Led mit Widerstand ->  Pin 16 (OUT 1)
    Leider bringt mit das nix, weil ich ja viele LEDS schalten will und die Ports des Mega32 diesen hohen ströme nicht verkraften.

    Zudem verwundert mich, dass bei meine tollen ULN2803AG die Eingänge anscheinend nicht invertiert sind :-/ d.h. der schaltet nur wenn auf dem Eingang 5V anliegen.

    Ich habe auch die schaltung schon mehrmals neu aufgebaut und es mit beiden ICs getestet .. immer mit dem selben Ergebnis ..

    Hab ich nen Denkfehler drin .. ???

    Wie bekomm ich die 12 V an die LEDs, so dass ich se über den ULN2803A regeln kann ..

    Ich bin für jede Hilfe dankbar.

    Gruß Achim

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.184
    Du hast keinen Denkfehler, wenn du +5V auf den Eingang des ULN legst, dann schaltet er durch und die LED die gegen +5V liegt leuchtet. Schau dir im Datenblatt die Schaltung an, dann wird das gleich klarer.

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    05.10.2006
    Ort
    Saarbrücken
    Beiträge
    13
    Wow .. das ging mal fix mit der Antwort.

    Vielen dank .. aber leider bin ich im Elektronikbereich ein blutiger Anfänger und das Datenblatt hat mir nicht wirklich weiter geholfen ..

    Heißt das ich habs richtig gemacht und nur die IC's sind doof

    Wie müsst ich es machen das er 12 V durchschaltet ?

    Warum gehts mit 5 V und mit 12 V nicht ?

    Fragen über fragen ..

  4. #4
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.184
    Das LED oder mehrere in serie mit Widerstand auf +12V
    Die andere Seite der LED auf z.B. Pin 16 des ULN
    Auf Pin 9 des ULN kommt GND von 5V und 12V, also beide GND zusammenschalten.
    Auf Pin 1 kommt der jeweilig Ausgang des Mega32
    Ich glaube du hattest es beim ersten mal richtig bis auf die Verbindung von GND

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    05.10.2006
    Ort
    Saarbrücken
    Beiträge
    13
    AMOK ... es funktioniert

    Hat nur das 2. GND gefehlt.

    1000 Dank ..

    Hatte schon alle möglichen kombinationen durchprobiert .. bis auf die sache mit den 2 GND's.

    Muss aber ehrlich gestehen, dass ich da nie von selbst drauf gekommen wär .. obwohls ja eigentlich logisch ist ...

    Nochmals vielen DANK ..

    Gruß Achim

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •