-         

Ergebnis 1 bis 4 von 4

Thema: harte LCD-Probleme

  1. #1
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    16.10.2006
    Ort
    Bayern
    Alter
    30
    Beiträge
    313
    Blog-Einträge
    1

    harte LCD-Probleme

    Anzeige

    Guten Abend zusammen,

    ich habe vor kurzem angefangen, mich mit Microcontrollern zu beschäftigen. Jetzt wollte ich ein LCD anschließen und Text darauf ausgeben. Das LCD habe ich von MIR Electronic in München, welche gerade ausverkauf haben, günstig bekommen, aber leider auch kein Datenblatt dazu.

    Da es allerdings einen HD44780A - Controller hat, bin ich von der Industriestandard-beschaltung ausgegangen und habe das LCD genau so angeschlossen.

    Es hat jedoch nichts außer einem dunklen Balken oben und einem hellen unten ausgegeben, und ich weiß nicht warum. Ich habe schon alle pot. Fehlerquellen, die mir einfielen geprüft (Lötfehler, Programmfehler, anderes LCD etc.) und auch jemand anderes, der davon eine Ahnung hat, hat schonmal drübergeschaut, konnte aber auch nix erkennen.

    Ihr seid jetzt meine letzte Hoffnung, hat hier irgend jemand ne Idee, an was es liegen könnte, oder was ich versuchen könnte???

    Freue mich über jede Antwort!!

    Mfg.
    LemonSq.


    P.S. Ach ja, der Prozessor ist ein ATTiny2313, das LCD ist an den Ports PB0..5 angeschlossen und der Prozessor steckt in dem Evaluationsboard V2 von Pollin.

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    08.05.2005
    Ort
    Issum
    Alter
    45
    Beiträge
    2.236
    hat hier irgend jemand ne Idee, an was es liegen könnte, oder was ich versuchen könnte???
    Ich habe eine Idee...

    Du postest einen Schaltplan, UND das Programm damit man die Glaskugel nicht auspacken muß.

    Gruß Sebastian
    Software is like s e x: its better when its free.
    Linus Torvald

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    01.03.2006
    Beiträge
    138
    Mit was programmierst du den ( Bascom, C ). Achtung es gibt zwei arten beim standard bei der einen ist links D7 ende und bei der anderen rechts. hast vielleicht was in deinem prog übersehen z.b. initialisieren oder was weis ich. was für ein quarz hast den (fuses).

    mfg

  4. #4
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    16.10.2006
    Ort
    Bayern
    Alter
    30
    Beiträge
    313
    Blog-Einträge
    1
    Hi @all,

    erstmal vielen Dank für die schnellen Antworten.

    Aber das Problem ist gelöst. Also, ich habe zuerst mir Assembler programmiert, und es dann auch noch mit der Demo von Bascom probiert.

    Aber das Problem lag darin, dass bei dem Board von Pollin eine 19 pin Stiftleiste benutzt wird, um die Anschlüsse nach außen zu führen. Und in der Beschreibung dazu ist ein Druckfehler !!! ARRG! Darauf muss man auch erstmal kommen.

    Trotzdem nochmal vielen Dank für eure Bemühungen.

    Gruß,
    (auch) Sebastian

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •