-         
+ Antworten
Seite 1 von 5 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 47

Thema: Mein erster "richtiger" Bot

  1. #1

    Mein erster "richtiger" Bot

    Hallo,

    Er ist natürlich noch lange nicht fertig.
    Es kommen noch Mehr Sensoren, Funkkamera schwenkbar (hab ich schon, ist aber noch nocht monitert), Funkmodem zur datenübertragung zum PC und eine Sprachausgabe.
    Momentan hat er nur ein Sensor, der SRF04 befestigt auf einem Servo. Damit kann er schon (fast) allen Hindernissen ausweichen. =D>
    Fortsetzung folgt...

    Gruss berry

    Videos:
    http://www.ba-com.ch/Videos/1.avi
    http://www.ba-com.ch/Videos/2.avi
    http://www.ba-com.ch/Videos/3.avi
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken bild3.jpg   bild2.jpg   bild1_494.jpg  

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    01.11.2003
    Ort
    Freiburg im Breisgau
    Alter
    28
    Beiträge
    2.624
    Hi berry!
    Der sieht ja garnicht so schlecht aus, für den 1. richtigen Roboter! *neid*
    Was sind das für Räder (Duchmesser usw.) und wo kann man die kaufen?

  3. #3
    so befor noch die hammermegaultra fragen kommen...
    mal was ganz simples...
    das is doch das RN Control board...
    wo hast du bitte das Servo angschlossen:
    ich hab 3 Kabeln (du auch )
    schwarz
    rot
    weis (da hast du gelb)
    also wo kommt was hin?

    mfg
    JavaMasta

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    29.01.2004
    Beiträge
    2.441
    das is doch das RN Control board...
    wo hast du bitte das Servo angschlossen:
    Guck mal hier: http://www.kreatives-chaos.com/index.php?seite=rnkc10

    Ein Controller mit 10 freien Pins für 10 Servos => nimm einfach den freien Pin der dir am besten gefällt.

    Ich meine allerdings in irgendeinem Thread gelesen zu haben, dass du die Servos über PWM ansteuern willst. Dann musst du das Steuerkabel natürlich einen PWM-fähigen Pin deines Controllers anschliessen. Welche das sind steht im Datenblatt.

  5. #5
    sry aber ich will das servo und den Fahrtenregler direkt ans Rn Control anschliessen, und da drauf sitzt ein ATMega 16...
    entweder bin ich blind, oder in dem 300seitigen datenblatt von atmel steht nichts von PWM (k ich bin blind)
    das einzige was ich weis ist, dass es 4 PWM ausgänge gibt =)
    aber gefunden hab ich es trotzdem nicht

    Ich meine allerdings in irgendeinem Thread gelesen zu haben, dass du die Servos über PWM ansteuern willst.
    steuert der Controller die Servos nicht auch über PWM an...wie denn sonnst?

  6. #6
    Die Räder haben ca. 10cm durchmesser. habe sie in einem baumarkt gekauft.
    Ja es ist das RN-Control Board.
    zum Servo:
    schwarze Kabel -> GND
    rotes Kabel -> +5V
    gelbes/weisses Kabel -> an einen freien Port
    Programmiert habe ich das ganze mit BASCOM. Damit kann man sehr einfach einen Servo ansteuern.

  7. #7
    check ich ned ganz...
    wenn ich das Servo ansprechen will, dass es in die einzelnen Stellungen geht (von 0-255) muss ich das ding an einen PWM Ausgang anschliessen, oder dreht dein servo nur volllinks oder vollrechts?

    ========================
    edit...die pwms sind auf den Timern?

  8. #8
    um ein Servo anzusteuern brauchst du kein PWM ausgang.
    schau dir das video an.
    mit Bascom geht das dann so:

    Config Servos = 1 , Servo1 = Portd.2 , Reload = 10
    Config Pind.2 = Output
    Enable Interrupts
    Servo(1) = 120

    anstelle von 120 kannst du die position des des Servos angeben. von 0 bis 255

  9. #9
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.943
    Blog-Einträge
    1
    Wie bereits gesagt, Bascom hat eingebauten Servo Befehl und kann über beliebige Ports bis zu 10 Servos ansteuern. Allerdings wird dazu ein Timer belegt.

    @beryllium: Bot ist garnicht schlecht. Und man sieht das es auch ohne großem Kabelgewirr geht. Platz ist jedenfalls noch genug da.

  10. #10
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.06.2004
    Ort
    Aachen
    Beiträge
    2.674
    Fehlen noch nen par mehr Sensoren oder??
    Aber die Plattform ist hammer, lässt ja noch einiges zu!
    Hast du hinten nen Nachlaufrad?
    Was frisst das Din an Strom (komplett)?? und was für Akkus hast du benutzt?

+ Antworten
Seite 1 von 5 123 ... LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •