-         

Ergebnis 1 bis 6 von 6

Thema: Wo steckt der Haken, LCD killt Stromversorgung

  1. #1
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    17.08.2004
    Beiträge
    1.065

    Wo steckt der Haken, LCD killt Stromversorgung

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Moin zusammen.
    Ich habe eine Platine für meinen Belichter gebaut, an Board ein LM2940-ct5 für 5V (Low Dropout, max 1A), ein Relais, ein PIC,der die Geschichte steuert, ein Piezosummer und Anschlüsse für Taster und ein LCD mit Hintergrundbeleuchtung.
    Im Anhang findet ihr ein Bild des Schaltplans, falls ne bessere Qualität gewünscht wird, melden.

    So. Ich habe also die Schaltung ans Netz angeschlossen, der PIC ist erstmal so programmiert, dass er den Summer im Intervall ansteuert. Das geht auch alles gut, wenn ich keine Taster und kein LCD dran habe. Ich messe eine Betriebsspannung von 4,96V, für die Hintergrundbeleuchtung liegen an dem Pin ca 4,2-4,5V an.
    Sobald ich nun ein LCD-Display dranstecke, bleibt es dunkel, die Frequenz des Piezos ändert sich und ich messe nurnoch max 2,7V Betriebsspannung, gerade genug für PIC und Piezosummer. Die LED an der Betriebsspannung leuchtet auch merklich schwächer.
    Wieso? Ist da irgendwo ein Kurzschluss wenn ich das LCD anstecke? dachte erst, es wäre das Kabel zum LCD, aber ich habe mal ein anderes probiert und direkt auf die Steckleiste gesetzt, selber Effekt.
    Ich dachte erst, die Hintergrundbeleuchtung zieht zuviel, also hab ich einen größeren Trafo genommen, der bei 6V 488mA liefern kann. Keine Verbesserung. Deswegen glaube ich, dass im Grundsätzlichen Schaltplan was schief läuft. Kann mal jemand einen Blick drauf werfen, besonders die Untere rechte Ecke, in der die LCD-Buchse mit Treibertransistor für die Beleuchtung ist?
    Meine Bedenken wegen dem Trafo und dem Linearregler lm2940 sind von meiner logik nicht so groß, der Trafo sollte beis 466mA immernoch 6V liefern, im Gleichrichter werden daraus dann nochmal 8,5V, was ausreichen sollte. Ich habe nochmal am Trafo gemessen, ohne LCD gibts 10V AC und nach dem Gleichrichter ca 15V DC, nach Anschluss des LCDs bricht die vor dem Gleichrichter auf knapp 4,3V AC ein, nach dem Gleichrichter bleibt noch weniger übrig!
    Danke und ich hoffe auf nen guten Tipp.
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken belichter_649.jpg  

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    25.07.2006
    Ort
    Berlin
    Beiträge
    439
    Versuch es mal ohne LCD-Beleuchtung, vielleicht liegt dort irgendwo der Wurm.

    Gruß
    Detlef

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    26.08.2006
    Beiträge
    84
    Schau mal nochmal ins Datenblatt von dem LCD, oft liegt auf Pin1 Gnd/Masse.
    Ich hoffe es liegt an was anderem...

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    17.08.2004
    Beiträge
    1.065
    ogott... ich hau mit dem kopp gegen die wand... ich hoffe das LCD lebt noch... klar, ich hab Vss und Vdd vertauscht, auch schon beim Schaltplan!

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    17.08.2004
    Beiträge
    1.065
    *verbeug* Ich, der König im Reich der Dummen und Leichtsinnigen, die meinen die Belegung auswendig zu können, verneigt sich vor deiner Weisheit, Slein, vielen, vielen Dank!

    Das LCD weilt noch unter den Lebenden und zeigt mir Stolz seine zweite Zeile als schwarzen Balken. Aber mit sovielen Fehlern bin ich drauf und dran eine Zweite Revision der Platine aufzuziehen... wenn ich noch genug SMD Widerstände habe und nen Nachmittag zum Ätzen.

  6. #6
    Benutzer Stammmitglied
    Registriert seit
    26.08.2006
    Beiträge
    84
    boah!
    das hats überlebt? Hab ich ehrlich gesagt nicht dran geglaubt.

    Erhebe er sich!
    Hab nur vor ein paar Tagen eins verbaut, sonst hätt ichs nicht gesehen. Und verstorben sind mir so auch schon genug Dinge

    Viel Erfolg noch mit dem Belichter!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •