-         

Ergebnis 1 bis 3 von 3

Thema: GP2D12 mit Atmega32

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    03.07.2006
    Beiträge
    143

    GP2D12 mit Atmega32

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo Zusammen!
    Ich habe ein Problem, sobald ich den Sharp-Sensor GP2D12 an PA0 anschliesse läuft mein Programm nichtmehr auf dem Atmega.

    Ich habe Vref und AVCC auf 5Volt.

    Pin1 (Vo) auf PA0; Pin2 Gnd; Pin3 +5V

    Der Sensor gibt mit auch nur eine Spannung von 0-0.3Volt was nach Datenblatt doch stimmen sollte?? Mit der Suchfunktion habe ich aber immer gelesen das der Output bei ca. 3Volt liegen soll??

    Kann mir jemand Helfen?
    Vielen Dank!!

  2. #2
    Super-Moderator Robotik Visionär Avatar von PicNick
    Registriert seit
    23.11.2004
    Ort
    Wien
    Beiträge
    6.836
    Nimm einmal den GP2D12 extra, nur GND und +5V und miß den Output.
    Je nachdem, wieweit du ihm was vor die Nase hältst, sollte er eine Spannung laut Datenblattkurve liefern.
    Wenn er das tut, ist er erstmal aus dem Schneider.
    mfg robert
    Wer glaubt zu wissen, muß wissen, er glaubt.

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    03.07.2006
    Beiträge
    143
    ich habe den Sensor nochmals ausgemessen, die Spannung scheint zu stimmen. 0.3- ca. 2.5 Volt keine Ahnung, vielelciht hatte ich das KO flasch eingestellt...

    Wenn ich einfach +5Volt an den Pin AD0 lege dan funktioneirt alles wunderbar, doch sobald der Sensor rannkommt scheint der Prozessor stillzustehen..

    ich glaube es ligt an meiner abelb^verlängerung am Sensor... ich mach das mal neu..
    Vielen Dank für deine Hilfe!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •