-         

Ergebnis 1 bis 6 von 6

Thema: Lcd Display mit KS0108

  1. #1

    Lcd Display mit KS0108

    Anzeige

    Hallo habe mir ein POWERTIP PG12864 mit ks0108 Chip zugelegt
    ich will nur Buchstaben und Zahlen darstellen das reicht.
    Ich kann es aber schon nicht compilieren .Was mache ich falsch???

    $regfile = "m16def.dat"
    $crystal = 8000000

    Config Graphlcd = 128 * 64 , Dataport = Porta , Controlport = Portc , Ce = 0 , Ce2 = 1 , Cd = 4 , Rd = 3 , Reset = 2 , Enable = 5

    Cls
    Locate 1 , 1
    Lcd "****hallo****"

    End

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    21.04.2005
    Ort
    Hannover
    Beiträge
    190
    Hallo iq250!

    Schau doch einfach mal in den Samples-Ordner unter KS0108.bas.
    ....oder in der Hilfe von Bascom.
    Das ganze liegt daran, dass das Display wahrscheinlich keinen eigenen Zeichensatz hat und du noch Fonts mit einbinden musst.

    Dann sieht das ganze in etwa wie folgt aus:

    setfont font8x8
    lcdat 1 , 1 , "Hallo Welt"
    end
    $include "font8x8.font"

    Ich habe das ganze auch probiert, nur leider kommt auf dem display nur mist raus, weil es wohl nicht richtig initialisiert wird.
    Viel Erfolg

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    23.11.2006
    Ort
    K-Town
    Alter
    39
    Beiträge
    178
    in die config graph zeile muß 128*64sed rein!

    und du mußt die lib für den ks108 einbinden!

    $lib "xxxx" -- weiß jetzt nicht auswendig wie sie heißt!

    dann funktioniert das compilieren!

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    23.11.2006
    Ort
    K-Town
    Alter
    39
    Beiträge
    178
    es müsste die LIB "glcdks108.lib" sein...

    befehl

    $lib "glcdks108.lib"

    Zapo.

  5. #5
    Hallo,

    ich habe auch ein Display mit dem KS108 Chip.
    Problem bei mir ist, dass er sich bei dem Befehl:

    Config Graphlcd = 128 * 64sed , Dataport = Porta , Controlport = Portc , Ce = 0 , Ce2 = 1 , Cd = 4 , Rd = 3 , Reset = 2 , Enable = 5

    aufhängt. Der Simulator, wie auch der Chip selber, wenn man das compilierte dann mal in den Chip schreibt.
    Ich habe allerdings nicht die besagte "glcdKS108.lib" in meinem Ordner ist die nicht enthalten.

    Viele Grüße Ralf

  6. #6
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Wenn man die Demo von Bascom hat, ist nur die "glcdKS108.lbx" dabei.
    Ist bei anderen Libs genauso.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •