-         

Ergebnis 1 bis 3 von 3

Thema: Syntax highlight bei Avr Studio

  1. #1
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    08.05.2005
    Ort
    Issum
    Alter
    45
    Beiträge
    2.236

    Syntax highlight bei Avr Studio

    Anzeige

    Hallo,

    Da ich auf meinem Laptop WinXp habe, habe ich mir gedacht, daß ich mal über den Tellerrand schaue,
    und AVR Studio in Verbindung mit winavr ausprobiere .

    So ist alles auch sehr schön, klappt sehr gut.
    Nachdem ich mir die Fuses an meinem Mega8 so verstellt habe,
    daß nichts mehr ging durfte ich noch das Highvolt Programmieren
    des STK500 ausprobieren .
    Die Debug Funktion fand ich auch sehr nützlich, alles perfekt und ich bin eigentlich damit zufrieden \/ .
    Was mir aber nicht so toll gefällt, ist, Syntax highlight von dem mitgeliefertem Editor.

    Entweder hab ich nicht gründlich genug gesucht, oder sind die Schalter um daran zu drehen ziemlich tief versteckt...

    Es wird nicht unterschieden ob es sich um eine Funktion,
    Variablendeklaration, Preprozessordirektive,
    oder um C internen Befehle handelt, alles ist einfach nur blau
    Und das automatische Einrücken konnte ich auch nirgendwo finden

    Es kann sein, daß ich mich jetzt etwas pingelich anstelle,
    es wäre aber nicht schlecht, wenn mir jemand sagen könnte,
    ob und vor allem wie man die Farben ändern kann und wie man das automatische Einrücken einschaltet.

    Vielen Dank fürs Lesen

    Gruß Sebastian
    Software is like s e x: its better when its free.
    Linus Torvald

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    10.08.2004
    Ort
    Großbardorf
    Alter
    30
    Beiträge
    674
    der Frage schließ ich mich an
    Ich programmiere seit neuerem auch mit avrstudio und winavr und hätte schon ganz gerne wieder "richtiges Syntaxhighlighting".

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    08.05.2005
    Ort
    Issum
    Alter
    45
    Beiträge
    2.236
    Hallo Pascal,
    schön das ich nicht alleine mit dieser Frage stehe, aber nachdem schon ein paar Tage vergangen sind, wo ich sie gestellt habe, und immer noch keine Antwort kam, gehe ich davon aus, daß man da nichts machen kann.

    Ich hab mir auch inzwischen minimales Gentoo auf meinen Lapi installiert, und kann wieder mit emacs arbeiten...

    Gruß Sebastian
    Software is like s e x: its better when its free.
    Linus Torvald

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •