-         

Ergebnis 1 bis 3 von 3

Thema: Input funktioniert nicht

  1. #1

    Input funktioniert nicht

    Anzeige

    Hallo,

    Ich habe mir vor einigen Tagen einen Atmel mega32 gekauft. Am anfang hatte ich schwierigkeiten mit dem Programmieren was jetzt auch nicht mehr so ist.

    Jetzt hat ich aber ein neues problem.
    Ihrgentwie funktionieren die Input pins nicht.
    output geht wunderbar (hab schon ein blinklich gebaut)

    ich habe an den pin Porta.0 eine led.
    an Porta.1 einen taster und an Porta.2 auch.
    (Sind am einen kontakt am eingangs pin und am anderen an GND)

    Ich habe es mit diesem code versuch und weiß nicht weiter.
    In der Simulation hat es funktioniert

    kann der controller kaputt sein?

    Code:
    Config Porta.1 = Input
    Config Porta.2 = Input
    Config Porta.0 = Output
    Porta.0 = 1
    Start:
    If Porta.1 = 1 Then
    Porta.0 = 1
    End If
    If Porta.2 = 1 Then
    Porta.0 = 0
    End If
    Goto Start
    Ich hoffe mir kann jemand helfen

  2. #2
    Super-Moderator Robotik Visionär Avatar von PicNick
    Registriert seit
    23.11.2004
    Ort
    Wien
    Beiträge
    6.836

    Re: Input funktioniert nicht

    Code:
    Config Pina.1 = Input
    Config Pina.2 = Input
    Config Pina.0 = Output
    
    Porta.0 = 1
    Start:
    If Pina.1 = 1 Then
    Porta.0 = 1
    End If
    If Pina.2 = 1 Then
    Porta.0 = 0
    End If
    Goto Start
    Pin / Port aufpassen ! (Type "Help" for help)
    mfg robert
    Wer glaubt zu wissen, muß wissen, er glaubt.

  3. #3
    Oh danke (was man so alles übersieht, hab ich echt nicht gesehen)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •