-
        

Ergebnis 1 bis 6 von 6

Thema: Asuro kaputt?

  1. #1

    Asuro kaputt?

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Mir hat Waste's idee mit dem infrarot-Hindernisdetektor sehr gefallen, deswegen habe ich es gleich ausprobiert. Doch seit dem ich den ir-sender und empfänger so umgebaut habe wie waste kann ich keine programme mehr flashen. immer wenn ich meinen asuro einschalte erkennt flash ihn einfach nicht und ,macht weiter mit dem "countdown" bis zum timeout
    Vorher war das programm von waste drauf mit dem man die entfernung messen kann. wenn ich es einschalt ist das lämpchen grün und wir nur machmal rot wenn ich den ir-empfänger abdecke. allerdings brachte auch beim erstellen der .hex-datei folgende fehlermeldungen:

    from test.c:4:
    C:/Programme/winavr/avr/include/avr/signal.h:36:2: warning: #warning "This header file is obsolete. Use <avr/interrupt.h>."

    und:

    from asuro.c:75:
    C:/Programme/winavr/avr/include/avr/signal.h:36:2: warning: #warning "This header file is obsolete. Use <avr/interrupt.h>."

    was das bedeutet weiß ich nicht, ich bin ein blutiger anfänger

    wie kann ich meinen asuro wieder zum laufen bringen?
    ich habe ein multimeter weiß aber nicht an welcher stelle ich messen muss um die funktionalität von empfänger und sender zu überprüfen.

    bitte helft mir [-o<

    AysTerHay

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Hallo,

    die Fehler bedeuten, das Du das neue WinAVR installiert hast, aber die alten Sourcen vom ASURO compilieren willst, doch da hat sich einiges geändert im WinAVR bzw. Avr-gcc.
    Es gibt hier auch irgendwo einen Link bei dem man die angepassten Asuro-sourcen holen kann.
    Schau mal bei Arexx.com oder asurowiki.de

  3. #3
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    08.08.2004
    Ort
    Zwolle
    Alter
    61
    Beiträge
    531
    Hallo,

    eigentlich braucht mann in 'asuro.h' nur die Zeile:

    #include <avr/signal.h>

    zu entfernen.

    Sonnst guck mal hier:

    http://home.planet.nl/~winko001/Asur...uAvrPagFrm.htm

    Gruss

    Henk

  4. #4
    Danke, die Fehler beim compilieren bringt er jetzt nicht mehr.
    Aber die .hex-dateien können immer noch nicht geflashed werden da asuro nicht erkannt wird.
    ich vermute das ich den Ir-empfänger beim einlöten zerstört habe. Weiß jemand wo ich was messen soll um rauszubekommen ob der empfänger-IC funzt? Ich bin nicht gerade der elektronikFreak, um es milde auszudrücken, müsst ihr wissen

  5. #5
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    08.08.2004
    Ort
    Zwolle
    Alter
    61
    Beiträge
    531
    Hallo,

    Du konntest mal messen ob die IR Sender und EMpfanger richtig an Asuro gelotet sind.

    Mit 'upc' ist die Atmega8L mikrocontroller gemeint.

    ---SENDER---

    - die Kathode oder dass Beinchen am abgeflachten seite sollte mit 0 Ohm (direkt) verbunden sein mit upc pin 3.

    - die Anode oder dass Beinchen am runde seite sollte mit 220 Ohm verbunden sein mit upc pin 17.

    ---EMPFANGER---

    - die linker Pin, Pin 1 sollte mit 0 Ohm (direkt) verbunden sein mit upc Pin 2.

    - die mittelere Pin, Pin 2 sollte mit 0 Ohm (direkt) verbunden sein mit upc Pin 8 (GND)

    - die rechter Pin, Pin 3 sollte mit 470 Ohm verbunden sein mit upc Pin 1 (VCC)


    Gruss

    Henk

  6. #6
    danke für deine hilfe, es war alles so wie du es beschrieben hast.
    So langsam verzweifle ich. Ich tue alles das es läuft aber es läuft nicht.
    ich werde mr einen neuen IR-empfänger kaufen, hoffentlich funzt es dann. [-o< [-o<

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •