-         

Ergebnis 1 bis 4 von 4

Thema: komparator ausgang schaltet nicht

  1. #1

    komparator ausgang schaltet nicht

    Anzeige

    guten abend!

    ich habe ein problem mit einem komparator, genaur gesagt einem lm339.
    nachdem die gesamte schaltung nicht funktioniert hat hab ich den komparator nur mit der mindest beschaltung betrieben.

    versorgung mit 10V, input+: 5V, input-: 0-5V, ausgang mit pull up (47k evt. zu klein?) auf versorgung.

    bei input- = 0V schaltet der ausgangstransistor durch, doch sobald die spannung nur ein bisschen steigt sperrt der transistor wieder!

    jemand eine idee was ich falsch gemacht habe??
    danke im voraus!

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    07.12.2005
    Ort
    Euskirchen-Großbüllesheim
    Alter
    67
    Beiträge
    2.063
    Haben die Eingänge (zumindest einer) Vorwiderstände ?
    Sieh Dir mal die Schaltung in dem Thread http://www.roboternetz.de/phpBB2/viewtopic.php?t=21790 an; da geht es auch um einen Komperator.
    MfG Karl-Heinz
    HobbyElektronik hier klicken ....

  3. #3
    die spannungen für die eingänge kommen von einem spannungsteiler.
    man kann sagen die beschaltung gleicht deiner in dem anderen thread bis auf die rückkopplung aber diese benötigt man meines wissens nur wenn man den komparator als schmitttrigger verwenden will?

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    17.04.2006
    Beiträge
    2.193
    Er sollte eigentlich solange sperren, bis Du am invertierenden Eingang die 5V vom n.inv. überschreitest, insofern macht eher der 339 was falsch, wenn er mit 0V am inv. Eingang ein low am Ausgang produziert.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •