-         

Ergebnis 1 bis 1 von 1

Thema: Probleme beim Mp3-Decoder VS1011B

  1. #1

    Probleme beim Mp3-Decoder VS1011B

    Anzeige

    Der Chip funktioniert im Grunde ohne Probleme, wäre da nicht en kleiner
    Haken: Bei der Mp3-Wiedergabe statt der Musik ist nur ein unschönes
    Piepen zu hören.

    Wie ich zur Annahme komme, dass der Chip sonst einwandfrei läuft sei im
    Folgenden kurz erklärt:

    - Test der Sci- und Sdi-Schnittstellen sowie der analogen Ausgabe: Dazu
    wurde der sog. VsSineTest gemacht, bei dem als Resulutat ein Ton
    bestimmter Frequenz zu hören ist. Um sicherzustellen, dass der Ton auch
    wirklich aus der aufgerufenen Funktion stammte, wählte ich
    unterschiedliche Frequenzen, woraufhin sich der Ton entsprechend
    änderte.
    - Um zu sehen, dass die Mp3-Daten auch wirklich korrekt eingelesen
    werden, überprüfte ich den vom Chip ausgegebenen Mp3-Header, dieser
    entsprach meinen Erwartungen.
    - Die korrekte Synchronisierung wurde getestet, in dem ich die vom Chip
    benötigte Zeit zum vollständigen Lesen der Mp3-Datei mit der von Winamp
    angegeben Zeit verglich. Dabei nahm ich Dateien gleicher Größe, jedoch
    unterschiedlicher Laufzeit. Auch hier war alles korrekt.


    Merkwürdig oder? Ich jedenfalls kann es mir absolut nicht erklären, da
    ja, nach den Tests zu urteilen, alles (Datenstrom und analoge Ausgabe)
    funktioniert.
    Angehängte Dateien Angehängte Dateien

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •