-         

Ergebnis 1 bis 2 von 2

Thema: Umstieg von Mega8 auf 16- LCD macht nun Probleme ????? HILFE

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    14.12.2005
    Beiträge
    161

    Umstieg von Mega8 auf 16- LCD macht nun Probleme ????? HILFE

    Anzeige

    Hallo zusammen,

    habe enorme Probleme mit einem LCD und nem Mega16.

    Ich habe die Software 100% bei einem Mega8 laufen.

    So neue LP gemacht Mega16 rein, Ports umgeschrieben usw.

    Nun zeigt das LCD (20*4) nur die berühmten Kästchen in der 1. und 3. Zeile.

    Ist beim Mega16 irgendwas, was beachtet werden muss das ich übersehen habe????

    Die Ports habe ich 100 mal kontrolliert die stimmen mit der HW überein.


    Code:
    $regfile = "m16def.dat"
    $crystal = 3686400
    $baud = 4800
    
    Config Lcd = 20 * 4
    Config Lcdpin = Pin , E = Portc.2 , Rs = Portc.3 , Db7 = Portd.4 , Db6 = Portd.5 , Db5 = Portd.6 , Db4 = Portd.7
    Beim Mega8 sieht der Code und der PINout so aus, der haut super hin:

    Code:
    $regfile = "m8def.dat"
    $crystal = 12000000
    $baud = 4800
    
    Config Lcd = 20 * 4
    Config Lcdpin = Pin , E = Portd.3 , Rs = Portd.2 , Db7 = Portd.7 , Db6 = Portd.6 , Db5 = Portd.5 , Db4 = Portd.4

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    14.12.2005
    Beiträge
    161
    ..... mann mann hat sich erledigt - JTAG war schuld. Klar hatte ja die Portc pins hergenommen...

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •