-
        

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 24

Thema: ATMega ADC-Beschaltung von AREF und AVCC

  1. #1

    ATMega ADC-Beschaltung von AREF und AVCC

    Anzeige

    Hi,


    zu meinem Problem: Der ADC ist noch ein kleines bisschen zu ungenau.
    Ich benutze das Pollin-Board, bei dem Ist AVCC so verschaltet:

    AVCC------------------ VCC
    |
    |
    100 nF
    |
    |
    ground

    Nun habe ich vor, noch eine Drossel von 10 uH (wie im datenblatt) rein zu schalten.

    AVCC ------------10uH---VCC
    |
    |
    100nF
    |
    |
    ground


    Das es das ganze genauer macht, ist ja schon bekannt,
    nun zu meiner Frage: Was mache ich mit AREF? Im moment liegt das einfach an AVCC .... (5V).
    Soll ich da auch noch ein Siebglied dran machen?!....

    Zu der Beschaltung von AREF steht leider auch nichts im Datenblatt, zumindest hab ich nichts gefunden.
    Es handelt sich um einen ATMEGA16/32.

    Grüße Moonwalker

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    21.10.2005
    Ort
    Erde
    Alter
    50
    Beiträge
    1.195
    Das hängt davon ab, was Du in ADMUX als Referenz (Bit6 und Bit7) ausgewählt hast. Dementsprechend ergibt sich die Beschaltung.

    In Deiner vorgesehenen Beschaltung (ARef und AVcc verbunden) machen nur die Modi Sinn, bei denen ARef oder AVcc die Referenzspannung bilden. Dann brauchst Du auch kein weiteres Siebglied.

    BTW, die Drossel wird eine erhebliche Verbesserung bringen. Achte auch darauf, dass der Kondensator möglichst dicht an AVcc und dem zentralen Massepunkt angeschlossen ist.

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    17.02.2005
    Ort
    Erfurt
    Alter
    52
    Beiträge
    134
    > Der ADC ist noch ein kleines bisschen zu ungenau.

    könntest Du diesen Fehler etwas genauer beschreiben ?

    Ist er ungenau, wenn Du Deinen Messeingang gegen GND legst?
    Zappeln die Werte?
    Wert ungenau, wenn Du eine höhere Spannung anlegst (z.B. 4,5V) ?

  4. #4
    Wir steuern einen Roboterarm, dessen Armstellung über Potentiometer eingelesen werden. (0-5 V).

    Der Arm soll nun beispielsweise zu 500 (Integerzahl) fahren. Diese Aktion schwankt aber, er fährt mal ein Stück weiter und mal ein Stück kürzer. Ungefähr stimmts immer.

    Da wir uns die Messwerte nicht genau anzeigen lassen, ist es nun schwer zu sagen an was es liegt. Die Spule hab ich gerade besorgt, werde nun das Siebglied einbauen und mal beobachten obs besser wird.

  5. #5
    Erfahrener Benutzer Robotik Einstein Avatar von Vitis
    Registriert seit
    06.01.2005
    Ort
    Südpfalz
    Alter
    43
    Beiträge
    2.240
    ich vermute mal schwankungen auf der Leitung vom Drehgeber.
    Störungen durch andere elektriche oder elektronische Baugruppen
    im Umfeld oder Abweichungen vom Drehgeber durch Temperaturänderung
    usw. usw.
    Vor den Erfolg haben die Götter den Schweiß gesetzt

  6. #6
    Es ist auf jeden Fall noch etwas besser geworden durch die Drossel.

    Habt ihr noch irgendeine Idee wie mans noch genauer hin bekommt?

  7. #7
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    21.10.2005
    Ort
    Erde
    Alter
    50
    Beiträge
    1.195
    Da musst Du schon ein paar mehr Informationen bereit stellen

    - Aufbau
    - Schaltung / Layout
    - ADC Frequenzen/Modi
    - Eingangsbeschaltung
    - Typ des Potis
    -...

  8. #8
    Ich habe jetzt noch einiges raus messen können, z.B. ist meine AREF leicht schwankend, also um 0,01V. Dann kann das ja nicht genau sein. Im Ruhezustand ist die Quelle absolut exakt auf 5.055V. (Ist das eigentlich zuviel?).
    Wenn ich ne Brücke von AVCC auf AREF mache, stimmen die Werte überhaupt nicht mehr.

    Wie könnte ich die Spannung an AREF optimal stabilisieren?

  9. #9
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    21.10.2005
    Ort
    Erde
    Alter
    50
    Beiträge
    1.195
    Was nimmst Du denn für den ADC als Referenz? VRef oder AVcc?

    Wie sieht die Schaltung aus?

  10. #10
    Es handelt sich um das Pollin-Board:

    http://www.pollin.de/shop/downloads/D810022B.PDF

    In diesem PDF befindet sich der Schaltplan.

    Da AREF hier über einen Pfostenstecker heraus geführt wird, habe ich es an einem zweiten Netzteil hängen. Wenn ich AREF auf VCC brücke, macht der Arm nur noch krampf.

    Wenn ich es an die zweite Spannungsversorgung hänge stimmt es fast, es handelt sich nur um ne leichte Schwankung der Positionen, die sich denke ich durch die Schwanken an AREF erklären lässt. (So bald der Arm fährt, schwankt die spannung leicht (ca. -0,01V).

    Warum geht es nicht wenn ich AREF auf VCC brücke?

Seite 1 von 3 123 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •