-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: PT1 Verhalten des Asuro Motors

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    18.03.2006
    Beiträge
    24

    PT1 Verhalten des Asuro Motors

    Anzeige

    Hallo Community,

    ich möchte mal selber einen PID-Regler für meinen Asuro machen. Weil ich aber keine Lust habe mit den ganzen mir unbekannten Trägheitsmomenten rumzurechnen, hab ich jetzt einfach die Beschleunigung von einem Rad unter Last (also au'm fußboden) gemessen. Heraus kommt die Kurve im Anhang. Sieht ja nett aus, aber irgendwie ist das kein richtiges PT1. Soll heißen ich bekomme keine Formel hin, die dieses Verhalten beschreibt...
    Die blaue Linie ist die gemessene Beschleunigung und mit der pinkfarbenen wollt ich die PT1-Funktion so anpassen das die zwei gleich sind.
    Da ich in diesem Thema noch relativ unbedarft bin, ist meine Frage ob ich das überhaupt so machen kann oder ob ich mit den Trägheitsmomenten rumrechnen MUSS. Oder gibt es eine schöne Möglichkeit wie ich den Verlauf beschreiben kann? Wär schön wenn man ein Programm hätte in das man nur seine Wertepaare eintippt und dann kommt die Funktion raus

    wär super wenn mir jemand helfen könnte
    lg Katja
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken ss.jpg  

  2. #2
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    16.11.2003
    Beiträge
    355
    du kannst die entsprechenden Faktoren Kp usw. auch empirisch (durch ausprobieren ermitteln) dann kannste dir das rumgerechne sparen

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    18.03.2006
    Beiträge
    24
    hm, das K ist 6600. Damit ich für t=unendlich auch auf die 6600 umdrehungen komme. Ich kann also nur das T verändern aber das bringts leider nicht wie man an der pinken Linie sieht

  4. #4
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    16.05.2005
    Beiträge
    734

    Re: PT1 Verhalten des Asuro Motors

    Zitat Zitat von Katja
    Die blaue Linie ist die gemessene Beschleunigung und mit der pinkfarbenen wollt ich die PT1-Funktion so anpassen das die zwei gleich sind.
    Da ich in diesem Thema noch relativ unbedarft bin, ist meine Frage ob ich das überhaupt so machen kann oder ob ich mit den Trägheitsmomenten rumrechnen MUSS.
    Doch, das geht schon.
    Wie sieht denn deine Formel für die pinkfarbene Kurve aus?

    Waste

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    18.03.2006
    Beiträge
    24
    die Formel für die pinkfarbene Kurve ist K*(1-e^(-t/T)) mit K=6600. für T hab ich mal verschiedene Werte eingesetzt aber meine blaue Kurve läßt sich damit nicht beschreiben

  6. #6
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    16.05.2005
    Beiträge
    734
    Die Formel ist richtig. T ist die Zeitkonstante, es ist der Wert, bei dem die e-Funktion 63% erreicht. Bei der blauen Kurve also ca. 20ms.

    Mir kommt der Wert aber sehr klein vor. Bei meinem Asuro hatte ich nie so eine gute Beschleunigung.

    Waste

  7. #7
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    28.06.2005
    Ort
    DD
    Beiträge
    519
    Hat es taktische Gründe, dass du deinen Thread über genau das Thema nicht erwähnst waste?

    MK

  8. #8
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    16.05.2005
    Beiträge
    734
    Nein, warum sollte ich!
    Da wir über PN das Thema bereits schon diskutierten, ging ich davon aus, dass sie den Thread schon kennt.

    Waste

  9. #9
    Neuer Benutzer Öfters hier
    Registriert seit
    18.03.2006
    Beiträge
    24
    danke für eure Antworten! Aber leider hab ich noch immer keine Ahnung was ich machen soll. Hatte eigentlich gedacht, daß man jede Kurve, die sich langsam an ihren endwert annährt durch die PT1-Formel beschreiben kann. Da man aber nur T verändern darf (K muß ja mein endwert sein) sind die Möglichkeiten ja doch ziemlich eingeschränkt...

  10. #10
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    16.05.2005
    Beiträge
    734
    Hallo Katja,

    nicht jede Kurve, die sich langsam dem Endwert nähert ist eine e-Funktion. Deine blaue Kurve sieht mir auch nicht danach aus, die ist anfangs viel zu steil und flacht danach zu sehr ab. Für eine praktische Messung ist sie mir auch viel zu glatt.

    Gruß Waste

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •