-         

Ergebnis 1 bis 4 von 4

Thema: Mal wieder ne PWM Geschichte...

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    02.12.2004
    Beiträge
    8

    Mal wieder ne PWM Geschichte...

    Anzeige

    Hallo Allesamt!

    Ich habe gerade mal wieder ein kleines denktechnsiches Problem mit einer PWM über Timer1. Will ein Bauteil ansteuern, welches mit einer Frequenz von 300Hz angesteuert werden möchte.
    Nun hab ich aber das Problem, dass ich bei einem 8MHz Quarz einfach nicht auf die benötigte Ausgangsfrequenz komme. Die Ferquenz die da am nächsten liegt sind 240 Hz mit Prescaler=64 bei einer 8Bit Auflösung.
    Gibt es irgend eine Möglichkeit hier ein passendes PWM-Signal zu generieren oder müsste ich mit einer Software-PWM arbeiten um das zu erreichen?

    Danke schonmal für Eure Tips,
    Martin

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    28.02.2005
    Ort
    Salzburg
    Alter
    37
    Beiträge
    464
    Die Prescaler sind bei Hardware PWM fest eingestellt.
    Software PWM wäre ein guter Lösungsansatz.

    MFG

    Bertl

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    02.12.2004
    Beiträge
    8
    Das blöde ist nur, dass dann der Prozessor viel langsamer wird was andere Funktionen angeht die er parallel ausführen soll, oder?

  4. #4
    Ich mache das immer so, dass ich nur 1nen Timer für mehrere PWMs verbrauche (Selbe Periodendauer, anderes Tastverhältnis) und dann die Tastverhältnise / Auflösung einfach durch die Wahl der Variablen Einstelle. Ich hab das auf nem PIC in ASM gemacht - ist nicht soo schwer.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •