-         

Ergebnis 1 bis 6 von 6

Thema: HILFE!!! stromloser AVR saugt Batterie des PCF8583 leer !!!

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    20.10.2004
    Ort
    Thüringen
    Beiträge
    133

    HILFE!!! stromloser AVR saugt Batterie des PCF8583 leer !!!

    Anzeige

    Hallo Leute,

    ich habe ein großes, mir unklares Problem.
    Habe einen PCF8583 Uhren-IC an einem Mega8 hängen.
    Läuft soweit prima. Nur leider ist die Stützbatterie nach einigen Tagen leer.

    Messungen ergaben, das der Strom über die SDA / SCL-Leitungen abfließt, wenn der AVR ohne Strom ist (Aber das ist bei mir meist lang, da die schaltung in ein Wochenendhaus eingebaut werden soll...)

    Das sind fast ein Milliampere!!! Entferne ich die SDA/SCL-Leitungen ist der Stromverbrauch aus der Batterie ca. 3µA. Das ist korrekt.

    Hat jemand dafür eine Erklärung, oder besser Lösung??
    Ich bin jedenfalls ratlos.
    Die Beschaltung des PCF ist entsprechend den ANs.

    Danke im Voraus.
    Andreas

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von SprinterSB
    Registriert seit
    09.06.2005
    Ort
    An der Saar
    Beiträge
    2.801
    Um welche Spannung handelt es sich denn?

    Wenn an SDA/SCL SPannung liegt, die größer ist als VCC+x, dann wird VCC über die internen Clamp-Dioden (zum ESD-Schutz) mit Saft versorgt.

    Der AVR ist also nicht stromlos.

    Da hilft dann nur die AKtivierung aller Sparoptionen, falls die Spannung zum Betrieb reicht. Reicht der Saft nicht zum Betrieb, hilf evtl was mit dem BOD, aber keine Ahnung, was die BOD an Sprom frisst...
    Disclaimer: none. Sue me.

  3. #3
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    28.02.2005
    Ort
    Salzburg
    Alter
    37
    Beiträge
    464
    Wenn am AVR keine Spannung anliegt, dann sind alle Pins auf eingang ohne Pullup geschaltet.

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von SprinterSB
    Registriert seit
    09.06.2005
    Ort
    An der Saar
    Beiträge
    2.801
    Da der AVR Saft über die Ports zieht, hilft vielleicht ein Analogmultiplexer oder Tri-State-Bustreiber in die Leitungen zu hängen.
    Disclaimer: none. Sue me.

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    22.04.2005
    Beiträge
    178
    Im Power-Down-Modus zieht der Atmega8 bei 5V etwa 1 µA, bei 3V sogar nur 0,3 µA, wenn du dann noch die zwei Pins auf Eingang schaltest und die Pullups deaktivierst sollte dein Problem gelöst sein.

    felack

  6. #6
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    28.03.2004
    Beiträge
    185
    Ich kann das Problem nicht bestätigen.
    Habe einen PCF8583 mit einem Atmega16 an Hardware I2C gekoppelt:

    Stromverbrauch aus Batterie wenn Atmega16 stromlos:
    Ubat=2,5V I=0,0023mA
    Ubat=3,7V I=0,0049mA

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •