-
        
+ Antworten
Ergebnis 1 bis 2 von 2

Thema: Falsche Pin-Belegung auf dem RNB-Bus

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    20.03.2004
    Ort
    Oberried
    Beiträge
    10

    Falsche Pin-Belegung auf dem RNB-Bus

    Ich gaube, es hat sich ein kleiner Fehler bei der Version 1.2 eingeschlichen:

    Die Pins 42 und 43 des RNB-Busses sind beide mit dem Port PD0, RXD, Pin 14 verbunden. Eigentlich sollte der Pin 42 mir Port PD1, TXD, Pin15 verbunden sein.

    Ich habe doch nicht falsch gemessen, oder?

    VictoriaOnSnow

  2. #2
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.943
    Blog-Einträge
    1
    Hallo,

    oh ja, Du hast recht! Pin 42 am RNBFRA Board 1.1 und 1.2 ist mit PD0 (RX) belegt. Richtig wäre PD1 TX. Ist mir doch noch ein Fehler rein gerutscht, tut mir leid! Danke für den Hinweis.
    Besitzer dieser Board-Version brauchen jedoch keine Panik bekommen, der Fehler hat keine Auswirkungen auf den normalen Betrieb sondern nur Auswirkungen auf Erweiterungen die diesen Stecker und diesen Pin benutzen. Bislang gibt es noch keine solchen, da bislang alle den I2C-Bus benutzen. Ich werde bei Erweiterungen dran denken und gegebenenfalls eine Lösung vorschlagen wie man das Manko umgehen kann, wenn der Pin mal gebraucht wird.
    Da PD0 aber sowieso gewöhnlich on Board für den Max232 gebraucht wird , wird es nicht oft vorkommen das er am Stecker benutzt wird.
    Bei der nächsten Platinenproduktion (wird dann 1.21 sein) ist das dann auch korrekt, hab eben das Layout schon geändert.

    Gruß Frank

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •