-
        

Ergebnis 1 bis 3 von 3

Thema: L297 L298N - Probleme mit zuviel Strom und Hitze

  1. #1

    L297 L298N - Probleme mit zuviel Strom und Hitze

    Anzeige

    Hallo Leute, bin komplett neu (im Forum), benötige für ein Projekt an einer Management-FH eine Schrittmotorsteuerung, eine Digitalkamera wird vertikal und horizontal bewegt

    habe von euerem Forum die L297, L298N Schaltung rausgesucht, erst auf Steckbrett aufgeaut, dann Platine gelötet (wilde Sache, da keine Erfahrung) und nach vielen hin und her ist jetzt folgendes Problem aufgetaucht:

    Motor: 5V, 1A; Schaltung mit 12V batterie und bei Sense-widerstand von 1 Ohm auf etwa 1V eingestellt (also unter 1A Strom)

    beide Motoren funktionieren - Ansteuerung über PC und USB-Umsetzbaustein IOW24 - doch der horizontal-Motor hat beim Einschalten, im Leerlauf 0,6 A und der L298 bleibt fast kalt, ebenso die Sense-Widerstände

    die Testschaltung, die nur auf einem Testbrett gesteckt ist, hat hingegen 1,35 A und wird schon heiß

    doch das wahre Problem ist der horizontale Motor, er hat beim Einschalten schon um die 2,5 A (somit um die 30W Leistung und Hitze), die Sensewiderstände sind sofort durchgeschmort, habe ich durch 5W Widerstände ersetzt - während der vertikale Motorleistungstreiber genau die gleiche Schaltung hat und kalt bleibt, wird der horizontale sofort knall heiß - habe jetzt Kühlblech so groß wie es ins Gehäuse passt reingegeben, doch das ist keine Lösung, es wird viel zu viel verbraten

    ausserdem, kleiners Problem: wieso pfeifen die Motoren so

    VERZWEIFELTER Student sucht Rettung in letzter Minute

    Grüße
    Reinhard

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    13.11.2004
    Ort
    München
    Alter
    30
    Beiträge
    447
    Hi,
    Warum drehst du den Strom nicht runter vom dem Motor der zu viel bekommt?
    Die L297/L298 Schaltung ist glaube ich für max. 2A... mehr ist nicht gut.
    Entweder du lässt weniger Strom fließen, versuchst es mit einem aktiven Kühler, oder nimmst eine L297/L6203 Schaltung(Die geht bis ~4A, sollte aber auch gut gekühlt werden).
    MfG Alex

  3. #3
    Hallo und herzlichen Dank für dein Interesse

    der Strom soll sich angeblich so einstellen lassen: über Referenzspannung an Pin 15 vom L297 - dort habe ich etwa 1V eingestellt

    der Motor: 5V, 1A - das gibt eine erlaubte Referenzspannung an Pin 15 vom L297: 1 x 1 x 1,41 = 1,41 Volt -ich habe aber nur 1V eingestellt, fahre den Motor noch unter 1 Ampere (evt muss ich eh raufgehen mit dem Strom, wenn er zu schwach ist)

    ausserdem: beide schaltungen sind gleich, beide motore sind gleich und doch ist eine Schaltung kalt beim einschalten und braucht 0,6 Ampere, während die andere sofort auf 2,5 raufschnellt (habe schon anderen L297 probiert, anderen L298N, Schaltung durchgesehen...) - kann es sein dass trotz der Referenzspannung sich ein höherer Strom einstellt?

    aufgefallen ist mir was nicht stimmt weil bei einer schaltung die Senswiderstände kalt sind (da waren es noch 1/4 Watt) und bei der anderen sofort durchschmorten

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •