-         

Ergebnis 1 bis 2 von 2

Thema: Problem mit L298

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    13.11.2004
    Ort
    Tutzing
    Alter
    26
    Beiträge
    198

    Problem mit L298

    Anzeige

    Hallo zusammen,

    ich habe folgendes Problem: Ich habe einen ATMEGA32. An diesen habe ich einen L298 angeschlossen, die Input Prots habe ich an Pb 0-3 und die Pwm Ports an Pd 4 und 5 angeschlossen. Ich versuche jetzt ein Programm zu schrieben, damit sicher der Roboter in einer bestimmten Geschwindigkeit im Kreis dreht. Hier mein Versuchscode mit dem es leider ned hinhaut. Hoffe ihr könnt mir helfen.


    Code:
    $regfile = "m32def.dat"  
                                       
    Ddrb = &B0000010
    Ddrd = &B0110000          
    
         Portd = &B0110000
    
         Portb = &B0000010
    
    End

    MfG
    Einen Virus für Windows? Das wäre ja dasselbe, wie wenn man
    eine Sabotage sabotieren würde.

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    03.01.2005
    Ort
    hessen
    Alter
    29
    Beiträge
    1.099
    hmmmm......glaube das Programm gibt keinen sinn würde das anders schreiben, du wiederholst dich auch in dem Programm


    mach das eher sodie Pins musste dann so an passen wie du sie hast)
    Code:
    $regfile = "m32def.dat" 
    $crystal = 7372800
    
    'pwm
    
    Config Timer1 = Pwm , Pwm = 8 , Compare A Pwm = Clear Down ,compare B Pwm = Clear Down , Prescale = 8
    
    dim z as word
    
    'richtung
    Config Pind.5 = Output
    links alias portd.5
    config pind.4  =output
    rechts alias portd.4
    
    do
      links = 0                                            ' PD.4 ist aus
      rechts = 1                                            ' PD.5 ist an
      Pwm1a = Z                                                 ' pwm1a(pinb.1) = a
       Z = 170
      
    loop
    end

    probiers mal so vielleicht klappt es ja.

    gruß
    patrick

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •