-
        

Ergebnis 1 bis 8 von 8

Thema: Chipwechsel von Atmega16 auf Atmega32; LCd geht nimmer

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    10.10.2005
    Ort
    Nähe Biberach a.d. Riss
    Alter
    47
    Beiträge
    44

    Chipwechsel von Atmega16 auf Atmega32; LCd geht nimmer

    Anzeige

    Hallo zusammen,

    ich hab meinen Mega16 gegen einen Mega32 getauscht.
    Nun geht das LCD Display nicht mehr. Es sieht so aus als ob es nicht mehr initialisiert werden würde.
    Wenn ich meinen Mega16 stecke, dann geht das Display wieder.
    Das Programm ist das gleiche wie im Mega16, Bascom hab ich darauf umgestellt und daß das Pogramm im Mega32 arbeitet ist auch sichergestellt (blinkene Led über T1)
    Der Prozessor kann eigentlicht nicht defekt sein weil neu und ein 2ter, Neuer tuts auch nicht.
    Meine Bascom- Version ist 1.11.8.2

    Wer weiss DA Rat???
    Kann doch ned an den Fusebits liegen - oder?

    Jürgen

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    10.08.2004
    Ort
    Großbardorf
    Alter
    30
    Beiträge
    674
    Vergleiche einfach mal die Fusebits. Eventuell ist ja eine falsche Taktrateneinstellung für das Problem verantwortlich.

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    10.10.2005
    Ort
    Nähe Biberach a.d. Riss
    Alter
    47
    Beiträge
    44
    Ne Taktrate passt (sehe ich am Blinktakt)
    Habs eben selber gefunden:
    Das JTAG Interface war enabled und deshalb gings ned.
    Man sollte halt dochmal öfters das Datenblatt konsultieren
    Trotzdem Danke

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    11.04.2005
    Beiträge
    1.469
    Hi,
    Kann doch ned an den Fusebits liegen - oder?
    Klar kann es.
    JTAG vielleicht noch enabled ?

    Gruß
    Christopher

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    10.10.2005
    Ort
    Nähe Biberach a.d. Riss
    Alter
    47
    Beiträge
    44
    STOP!!!
    Ich habs doch schon gefunden!
    Mei, geht dees hier abba schnell mit den Antworten =D>

  6. #6
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    11.04.2005
    Beiträge
    1.469
    LOL
    Zur gleichen Zeit gepostet
    Naja, schön wenn's jetzt geht

    Gruß
    Christopher

  7. #7
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    11.11.2005
    Beiträge
    321
    erst denken... dann meckern....(scheiss bayern)....

  8. #8
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Da wird ja nicht einer neidig sein
    Oder hast Du dich im Thread vertan, wer hat gemeckert ?

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •