-         

Ergebnis 1 bis 9 von 9

Thema: Kann nichts mehr kompilieren

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    05.01.2005
    Beiträge
    130

    Kann nichts mehr kompilieren

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hi,
    keine Ahnung, ob das hier in der richtigen Kategorie ist, aber ich kann seit ein paar Stunden nichts mehr für meinen Asuro kompilieren. Sobald ich irgendeine Datei kompilieren will (Und jede hat ne eigene Makefile), bringt er folgenden Fehler:
    Code:
    make all 
    MAKE Version 5.2  Copyright (c) 1987, 2000 Borland
    Error makefile 222: Colon expected
    Error makefile 247: Too many rules for target '%.o'
    Error makefile 283: Command syntax error
    *** 3 errors during make ***
    
    > Process Exit Code: 1
    Das ganze war gestern Abend schonmal, aber nach ein paar mal probieren ging es wieder.
    Weiß irgendjemand, was der Fehler sein könnte?


    mfg
    Spessi

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    21.10.2005
    Ort
    Erde
    Alter
    50
    Beiträge
    1.195
    Welche Umgebung?

    Bei mir kommt WinAVR mit gnu-make. Du hast Boarland make. Vielleicht stimmen Deine Pfade nicht und er nimmt das falsche make.

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    05.01.2005
    Beiträge
    130
    Verdammt, das kann es sein, ja.. Hab gestern abend Delphi installiert und seitdem geht es eigentlich nichmehr.. Stimmt! Was kann ich da jetzt machen? Wenn ich WinAVR neu installier, geht ja dann Delphi nich mehr, oder? [/right]

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    21.10.2005
    Ort
    Erde
    Alter
    50
    Beiträge
    1.195
    Falls Du WinAVR benutzt sind die Pfade normalerweise eingestellt (s. Screenshot). So was ähnliches müsste es in den Delphi Dialogen ja auch geben.

    (Screenshot gelöscht wg. Platzmangel, ogni42)

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    05.01.2005
    Beiträge
    130
    Ähm, wo ist der Dialog auf dem Screenshot? Hab WinAVR, aber als IDE nutz ich PN2

  6. #6
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    05.01.2005
    Beiträge
    130
    Ok, so gehts auch: Einfach die Test-all.bat ändern....
    C:\WinAVR\utils\bin\make.exe all

  7. #7
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    21.10.2005
    Ort
    Erde
    Alter
    50
    Beiträge
    1.195
    Der Kasten unten: Use External Tools. Da musst Du die Pfade anpassen, falls da was falsches drin steht. Im PN2 gibt's da vielleicht etwas ähnliches. Ansonste so vorgehen wie Spessi vorgeschlagen hat.

  8. #8
    Neuer Benutzer Öfters hier
    Registriert seit
    20.04.2006
    Beiträge
    10
    Zitat Zitat von Spessi
    Ok, so gehts auch: Einfach die Test-all.bat ändern....
    C:\WinAVR\utils\bin\make.exe all
    Moinsen, Spessi,

    ich hab' auch das Problem mit Borland. Wenn ich die Test-all ändere und im Programmers Notepad kompilieren will, kommt bei mir aber folgende Meldung:

    E:\ASURO_src\FirstTry>E:\ASURO_src\FirstTry\make all
    Der Befehl "E:\ASURO_src\FirstTry\make" ist entweder falsch geschrieben oder konnte nicht gefunden werden.

    ... Was muss ich noch ändern?

    Grüsse vom ölgötz

  9. #9
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    08.08.2004
    Ort
    Zwolle
    Alter
    61
    Beiträge
    531
    Hallo bin ja nicht sicher aber vielleicht geht's so:
    (ich nehme an das 'Path' sollte geanderd werden)

    -> Rechten mouseclick 'My Computer'
    oder
    -> Start -> Settings -> Controlpanel -> System
    -> Advanced
    -> Environment variables
    -> system variables -> Path -> Edit

    Jetzt kann mann die Verzeichnisse reienfolge wo das system nach executables such andern.

    Bei mir stehen
    C:\WinAVR\bin\
    und
    C:\WinAVR\bin\utils
    voran.

    So wenn ein 'make' oder sonstiges ausgefuhrt werden soll sucht das system zuerst im WinAVR verzeichnis.

    gruss

    Henk

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •