-         
+ Antworten
Ergebnis 1 bis 4 von 4

Thema: Noob : Kein ACS beim ändern der Geschwindigkeit??

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    29.04.2004
    Beiträge
    16

    Noob : Kein ACS beim ändern der Geschwindigkeit??

    Hallo, seid gegrüsst.
    Seid gestern habe ich nun auch den Robby und hab mich während der Ladezeit gleich hier durch das Forum gewühlt. Erst mal Lob -> gutes Forum, einige fähige Leute. Von denen benötige ich mal nen Rat :
    Habe alle Sensoren meines Robbys mit den Beispielprogs getestet, wirklich klasse, er hat auf alles reagiert. Auch das ACS funktioniert recht ordentlich nur muss ich ihm noch beibringen geradeaus zu fahren, denn fährt er parallel zu einem Hindernis kann es sein, dass er schräg drauf zufährt und fies aneckt.

    Als letztes liess ich 4_EINFÜHRUNG_ANTRIEB.bas laufen und da passierte es :
    Mein Robby fetzte los - mit irrer Geschwindigkeit und dabei wickelte sich die linke Gummikette aus der Führung. Mit einem todesmutigen Hechtsprung gelang es mir den kleinen vor einem Erkundungsflug duchs Treppenhaus zu bewahren, denn darauf steuerte er eiernd zu - unter massivem Blinken der ACSangesteuerten LEDs.

    Ich beschloss die Fahrtgeschwindigkeit zu drosseln um sicherzustellen dass die Ketten nicht aus der Führung geraten. Nun habe ich alle SPEED_L und SPEED_R - Werte halbiert und das Programm erneut übertragen. Zu meinem grossen Erstaunen fährt Robby nun zwar langsamer, aber dafür schnurstracks gegen die erstbeste Wand.

    Wieso denn blos ?? Kann jemand helfen ? Woran liegt das ?

  2. #2
    Super-Moderator Lebende Robotik Legende Avatar von Manf
    Registriert seit
    30.01.2004
    Ort
    München
    Alter
    63
    Beiträge
    12.204
    Ich sollte vielleicht nichts sagen, da ich den Robby nicht habe, aber ich habe schon einmal von Hechtsprüngen knapp vor der Wand gelesen.
    Hilft da nicht ein gutes Buch oder ein kleines Podest auf das man den Robby stellen kann, soaß seine Ketten erst mal in Leere greifen, bis man die Sensoren ausprobiert hat?
    Die Sensoren sollten doch auf eine Wand oder ein Stück Papier das vor ihm auftaucht reagieren. Wenn sie auf Papier reagieren, warum nicht auf die Wand? Gewächshaus?
    Aber wie gesagt den Robby habe ich nicht.
    Manfred

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    29.01.2004
    Beiträge
    2.441
    Auch das ACS funktioniert recht ordentlich nur muss ich ihm noch beibringen geradeaus zu fahren, denn fährt er parallel zu einem Hindernis kann es sein, dass er schräg drauf zufährt und fies aneckt.
    Wenn ich jetzt kleinlich wäre, würde ich einwenden, dass dein Robby rein per Definition eigentlich gar nicht an dem Hinderniss anecken kann, wenn er wirklich parallel dazu fährt

    Ich vermute mal, du möchtest im beibringen geradeaus zu fahren, damit er wenn er einmal paralllel zu einem Hinderniss fährt auch auf der Parallelen zu dem Hinderniss bleibt.
    Da ist dann aber schon das nächste Problem. Ausser Geradeausfahrt, müsstest du ihm noch beibringen eine parallele Bahn zum Hinderniss einzunehmen, wenn er eines entdeckt. Wenn er in einem leeren Raum parallel der Wand entlang fährt, könnte das theoretisch gelingen, wenn er kurz vor der nächsten Wand exakt 90 Grad abdreht. Praktisch wirst du die exakt 90Grad aber wohl nicht erreichen und das paradoxe ist dann - je näher du an die 90 Grad rankommst, desto spitzer ist der Winkel mit dem er dann auf Wand zufährt. Und je spitzer der Winkel, desto grösser ist wie du ja selber sagts die Gefahr, dass er diese Wand nicht "sieht" und dran aneckt.
    Ausserdem sind die meisten Räume auch nicht komplett leer und es gibt noch andere Hindernisse.
    Deswegen würde ich an den Robby erst mal mindestens einen "passiven Rammschutz" anbauen, damit er sich nicht die vorderen Dioden abfährt.
    Eleganter wären natürlich irgendwelche "bumper" mit Sensoren, damit er auch merkt wenn er irgendwo gegen fährt.
    Ihm beizubringen geradeaus zu fahren ist natürlich trotzdem sinnvoll.


    Ich glaube aber das geht alles an deiner eigentlichen Frage vorbei.
    Wenn ich dich richtig verstanden habe, meinst du, dass die Sensoren, bzw. das ACS nicht funktioniert, wenn die Motoren nur mit halber Kraft laufen.
    Falls ich das so richtig verstanden habe, kann ich mir da eigentlich keinen plausiblen Grund für vorstellen.

    Du könnetst dein Programm mal hier posten, dann lade ich es in meinen Robby und probiere ob der sich genauso verhält.
    Vielleicht liegt der Fehler auch irgendwo im Programm, da wäre der gepostete Programmcode ebenfalls nützlich.

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    29.04.2004
    Beiträge
    16
    Äh hi
    Lag wohl daran, dass ich nen Beep Befehl immer vor dem links oder rechts abbiegen eingefügt hab... Das mag er gar nicht... do geht nix meh [-( Wieso weiss ich noch nich.

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •