-         

Ergebnis 1 bis 5 von 5

Thema: Analogheingang flackert

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    30.01.2006
    Beiträge
    5

    Analogheingang flackert

    Anzeige

    Hallo! bin neu hier und habe von Elektronik kaum Ahnung.
    Will das aber jetzt ändern.
    Habe da ein Projekt bei der ich über die C-Control in zusammenhang mit einem PC sie zum Steuerung und Regeln nutzen möchte.
    Baue mir zurzeit eine Simulationsbox um die Analog sowie auch die Digitalausgänge und einen PWM siemulieren kann.
    mei erstes Problem ist das ich alle acht Analogeingänge über einen Wählschalter mit 8Stellungen und einen 50 K Podie anspreche!
    wenn ich meinen Wählschalter auf einenj Ausgang stelle klappt an dem Kanal alles prima aber die anderen 7Kanäle flackern.
    was muss ich noch mit reinschalten das die anderen Kanäle definiert 0Volt anzeigt wenn der Wählschalter nicht auf dem Kanal steht.

    2. Frage
    Muss ein wenig mit einem Pulsweitensignal spielen.
    Wie kann ich es Siemulieren oder etwas bauen um es zu Simulieren.
    Besten Dank schon im voraus hoffe habe mein Problem verständlich schildern können.

    Achtung! Bin kein Elektroniker also einfach erklären wäre sehr gut.

    Tschau bin schon auf die ersten antworten gepannt und auch sehr dankbar dafür.
    Gruß
    Uwe

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    02.11.2005
    Alter
    42
    Beiträge
    1.140
    Zu Frage 1)
    Die Eingänge "flackern", weil sie in der Luft hängen, also einen undefinierten Zustand haben. Wenn Du alle ADC-Eingänge mit einem hochohmigen Widerstand mit Vref verbindest, sollte das Problem behoben sein. Allerdings solltest Du dann das Poti kleiner wählen, da Du sonst einen zu hohen Spannungsabfall am Poti hast. Ich würde maximal 1k nehmen.

    Zu Frage 2)
    Mit einem NE555 kannst Du Dir sehr leicht einen PWM-Generator aufbauen. Einen Schaltplan dazu findest Du unter http://www.atx-netzteil.de/pwm_mit_ne555.htm

    Gruß,
    askazo

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    30.01.2006
    Beiträge
    5
    Danke und sorry für das doppelte einstellen bin auch was die Benutzung was Forenj angeht Anfänger aber schon sehr positiv überrascht.

    Wie groß würdest du den hochohmigen wiederstand wählen?

    Gruß Uwe

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    02.11.2005
    Alter
    42
    Beiträge
    1.140
    Kein Problem.
    Ich würde den Widerstand 250k - 500k wählen.
    Je größer die Differenz zwischen Poti und Widerstand, desto weniger Spannungsverlust hast Du beim messen.

    Gruß,
    askazo

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    30.01.2006
    Beiträge
    5
    Danke werde ich mir gleich morgen besorgen.
    Habe da noch eine Ide!
    Muß doch ein PWM Simulieren und einlesen um ein Programm zu testen.
    Meine M-Unit 1.2 hat ja 2 PWM Ausgänge ob ich da evt. direkt ein Programm schreibe um ein Signal zu erzeugen und es ausgebe und gleichzeitig an einem Digitaleingang wieder einlese.
    Was meinst du. Geht das evt. ???
    Gruß Uwe

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •