-         

Ergebnis 1 bis 6 von 6

Thema: Wer kennt sich mit Velleman-Board (K8048) und PARSIC aus?

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    13.01.2006
    Beiträge
    7

    Wer kennt sich mit Velleman-Board (K8048) und PARSIC aus?

    Anzeige

    Hallo,
    Besitze das Velleman-Board VM111(K804 und Parsic.
    Problem: Die Demo's die von Velleman mitgeliefert worden sind funktionieren einwandfrei(kompelieren in HEX, Brennen, Funktion)! Jedoch die auf Parsic erstellten Schaltungen funktionieren nicht(kompelieren in HEX, Brennen ja, aber Funktion Nein)!!!
    Was mache ich falsch?
    Könnte es sein, da die .asm Dateien von Parsic und die von VELLEMAN sich im Aufbau sehr unterscheiden, noch zusätzliche Variablen mit in die von Parsic erstellte Datei eingebracht werden müssen, so dass die Anwendung auf dem P16F627 richtig gebrannt wird.
    Deshalb Suche ich Anwender, die sich mit dem Velleman-Board VM111(K804 vielleicht sogar mit Parsic, gut auskennen.
    Für Jeden Tip/Hinweis bin ich Dankbar!!!

    Gruss

    tueftlerQ

  2. #2
    Benutzer Stammmitglied
    Registriert seit
    08.08.2005
    Ort
    RP, Westerwald
    Beiträge
    50
    Hallo,
    ich kenne mich mit Parsic aus. Hab damit angefangen. programmiere jetzt in Asm.
    Du musst bei Parsic unter Einstellungen Microcontr. den richtigen Controller einstellen.
    Dann musst du noch unter Tools/ Tools konfigurieren MPLAB einstellen und im Feld Parameter $PJT eingeben.
    Mit deinem Board kenne ich mich nicht aus. Hoffe Das bringt dich weiter! Sonst hatte ich mit Parsic keine Probleme.

    Gruß David

    edit: Das hab ich noch gefunden. Teil der E-Mail die ich bei der bestellung bekommen hab.


    Um vollständige Programme erstellen zu können,
    benötigen Sie MPLAB 5.50 oder höher, aber nicht Mplab 6.xx.

    www.microchip.com http://www.microchip.com/1010/pline/...ab5x/index.htm

    Die ersten Einstellungen die Sie machen sollten:

    1. Menü -> Einstellungen -> Programme:
    Das Programm MPASMWIN.EXE suchen.

    2. Menü -> Tools -> Tools konfigurieren:
    Das Programm MPLAB.EXE suchen und
    als Parameter $PJT angeben.(Großbuchstaben)

    Gruß

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    13.01.2006
    Beiträge
    7

    Liegt es an der Software Velleman-Board VM111(K8048)

    Soweit habe ich es, wie XDavidX ( meinen Dank!)vorgeschlagen hat, erledigt.
    Allerdings wurde mir mit der Software von Velleman das Progr. MPASMWIN, mit dem ich ja aus der .asm Datei eine HEX Datei generiere, mitgeliefert.
    Ich denke mal, dass das Progr. MPLAB dann nicht erforderlich ist.
    Mit dem Progr. PROCPIC2, ebenfals von VELLEMAN, brenne ich den PIC 16F627.

    Wer kennt sich mit dem Programmer Experimentier-Board VM111(K804 und der mitgelieferten Software aus?
    Meinen Dank an alle, die mir bis jetzt geholfen haben!

    Gruss
    tueftlerQ

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    08.08.2005
    Ort
    RP, Westerwald
    Beiträge
    50
    Hallo,
    also ich vermute das es doch daran liegt wie du assembelst.
    Der Hersteller von Parsic sagt ja das es nur mit der Version 5.xx geht,
    und nicht mit der 6.xx. Weiß nicht ob es auch verschiedene Versionen
    von MPASM gibt.
    Wenn du bei Microchip die angegeben Version (5.xx) von MPLAB runter
    lädst dann ist auch die richtige Version von MPASM dabei.
    Schau mal welche Version du hast. Bei mir ist es die Version 03.20
    (in MPASM unter Help/About), die klappt…

    Gruß David

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    13.01.2006
    Beiträge
    7

    David's Info könnte der richtige Weg sein!?

    Hallo,

    ja, ich denke David könnte recht haben! Das MPLAB 5.xx ist eine 16-Bit-Version!!!! Das Programm PARSIC 3.4.3 ist, nach meiner Meinung, eine ältere Version welches auch auf der Basis von 16 Bit arbeitet.
    Als letztes , was die Schwierigkeiten bringen könnte wäre das Brennpeogramm PROGPIC2, welches ich von VELLENAN mitbekommen habe.
    Könnte es sein, dass das PROGPIC2 mit dem von MPLAB 5.xx erstellten .HEX-Code nicht richtig arbeitet, da bisher alles im 16 Bit-Mode arbeitet?
    Ich selber benutze das WINDOWS-XP.

    Gruß und meinen Dank noch einmal!

    vom TueftlerQ

  6. #6
    Hallo
    ich benutze Parsic auch seit längerem für kleinere Sachen, die man mal
    schnell hinklatschen will, und es nit auf genaue zeiten ankommt.
    (ziemlich kritisch bei vielen timern)
    hab' 3.48, und lasse das mit MPLAB 7.10 compilieren ... bis jetzt keine
    Probleme.... vielleicht hilfts
    mfG Borny

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •