-
        

Ergebnis 1 bis 6 von 6

Thema: Mega32 nach umschalten auf ext. Quarz nicht mehr ansprechbar

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    09.10.2005
    Beiträge
    17

    Mega32 nach umschalten auf ext. Quarz nicht mehr ansprechbar

    Anzeige

    Hallo,

    habe heute eine Schaltung mit einem MEGA32 in Betrieb genommen.
    Lief anfänglich auch ganz gut - der MC ließ sich ohne Probleme programmieren. (ich nutze den Prog-Dongel mit dem 74HC244)
    Nachdem ich jedoch mit Hilfe der FUSE BITs auf den ext. Quarz (16MHz) umgeschaltet hatte, ging gar nichts mehr. Der Controller war nicht mehr ansprechbar, ließ sich nicht mehr programmieren, wurde nicht mehr erkannt - auch die FUSE BITs ließen sich nicht wieder zurücksetzen.

    Bei einer anderen Schaltung benutze ich das gleiche Programmierkabel an einem MEGA8 - der läuft ebenfalls mit 16MHz. Hier gab/gibt es gar keine Probleme.

    Habe zum Test auch den Controller (MEGA32) gegen ein zweites "jungfräuliches Exemplar" getauscht. Der verhielt sich aber genau wie der Erste. Nach dem Setzen der FUSE BITs ging nichts mehr.

    Hat jemand eine Idee, woran das liegen kann?

    Vielen Dank!

    ULF

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    08.05.2005
    Ort
    Issum
    Alter
    45
    Beiträge
    2.236
    Hat jemand eine Idee, woran das liegen kann?
    Ich hab eine Idee....
    Du hast die Fusebits auf externen Oscillator eingestellt, und jetzt möchte er einen Takt an xtal1, und wenn Du hier im Forum suchst findest Du sicher 1243 Beiträge von Leuten, die auch das selbe Problem hatten...
    Es kann auch sein, daß ich mich täusche, und das Problem liegt irgendwo anders.

    Gruß Sebastian

  3. #3
    Erfahrener Benutzer Robotik Einstein Avatar von Andree-HB
    Registriert seit
    10.12.2004
    Ort
    Bremen
    Alter
    47
    Beiträge
    2.556
    Danke an Alle, die uns bei der erfolgreichen 1.000€-Aktion der IngDiba unterstützt haben! | https://www.hackerspace-bremen.de | http://www.pixelklecks.de |

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    09.10.2005
    Beiträge
    17
    Hallo Zusammen,

    erstmal vielen Dank für den Tipp ... ich werde das gleich mal ausprobieren.
    Kann ja mit dem Experimentierboard auf dem der MEGA8 werkelt, ein prima Taktsignal erzeugen.
    Ich glaube aber nicht, dass ich die FUSE BITs auf den ext. Oszillator/Takt gestelt habe. Ich bin mir zu 99,9% sicher, dass ich beim MEGA32 die Einstellung "1111:1111" (ext. XTAL) gewählt habe. Es kann natürlich sein, dass Bascom dieses Setting nicht richtig implementiert hat und statt der korrekten Bitkombination einen anderen Wert an den MC schickt. Aber da wären wohl sicher schon andere drüber "gestolpert". Ich melde mich nochmal!

    Danke & Gruss,
    Ulf

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    09.10.2005
    Beiträge
    17
    So, habe zunächst mal den 16MHz-Quarz gegen einen 4MHz-Quarz ausgetauscht ... jetzt geht es wieder!!! Die FUSE BITs waren es also nicht !
    Trotzdem wüsste ich gern, warum mein MEGA32 nicht mit 16MHz laufen will.
    Möglicherweise ist auch der Quarz defekt - werde mir morgen mal einen neuen besorgen. Die FUSE-Einstellung war übrigens " 1111:Ceramic resonator/Crystal, BOD enabled" und nicht wie o.a. "1111:1111" (so ist nur dem MEGA8 eingestellt)

    Gruss, ULF

  6. #6
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    08.11.2005
    Ort
    QTH: JO43BC
    Alter
    49
    Beiträge
    112
    Mit den Fusebits habe auch ich in Anfaengerzeiten mal den boesen Fehler gemacht. Aber dieser schnell zusammengebastelter Adapter hat den ATMega wieder belebt. Den ATMega oben drauf und das ganze wieder in den Sockel der Anwendung. Fusebits wieder umprogrammiert. Und alles wird gut. :)

    http://www.elektronik-web.de/atmel/adapter.jpg

    Und solche Quarzoszillatoren hat doch jeder AVR-Bastler in seiner Kiste!? ;)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •