-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: PWM

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    21.10.2005
    Beiträge
    10

    PWM

    Anzeige

    Hallo.

    Ich bin neu hier.
    Habe erst vor kurzen mit dem Roboterbau an gefangen.
    Habe folgendes Problem bei der Ansteuerung oder besser gesagt beim dimmen meiner Motoren:
    Ich verwende erstmal keine MyC´s weil ich mich nicht damit auskenne und hab mir eine Schaltung bebaut die ein PWM erzeugt in TTL-Technik.
    Wollte dieses Signal von BIP-Transistoren verstärken lassen und dann über FET´s zu den Motoren. Leider steuern die Fet´s nicht richtigb durch. habe schon 2 verschiedene probiert (IRF520 und BUZ72a). Auch die BIP-Transistoren verstärken das PWM-Signal von den TTL´s fast garnicht. Ich arbeite mit 9V. Aus den TTL´s kommt was leicht über 4V raus. Die Transistoren hängen mit C an 9V und mit B natürlich am PWM-Signal. Sie bringen aber nur was leicht über 4V am E zusammen. Damit kann man freilich keinen FET richtig durchschalten.

    An was kann das liegen?

    Ist die Frequenz zu niedrig (ca. 5kHz).
    Wie kann ich dieses 4V-PWM-Signal auf 9V-Amplitude bringen? Muß ich da bei der Beschaltung der Transistoren vieleicht etwas beachten weils ja keine Gleichspannungsverstärkung mehr ist?

    Freue mich über jede hilfreiche Antwort.

  2. #2
    Super-Moderator Lebende Robotik Legende Avatar von Manf
    Registriert seit
    30.01.2004
    Ort
    München
    Alter
    64
    Beiträge
    12.372
    Die Kollektorwiderstande der Transistoren nach 9V wie groß sind die?
    1KOhm?
    Manfred

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    11.09.2004
    Ort
    Düsseldorf
    Beiträge
    3.948

    Re: PWM

    Zitat Zitat von Schorschi
    Hallo.

    Ich bin neu hier.
    Habe erst vor kurzen mit dem Roboterbau an gefangen.
    Habe folgendes Problem bei der Ansteuerung oder besser gesagt beim dimmen meiner Motoren:
    Ich verwende erstmal keine MyC´s weil ich mich nicht damit auskenne und hab mir eine Schaltung bebaut die ein PWM erzeugt in TTL-Technik.
    Wollte dieses Signal von BIP-Transistoren verstärken lassen und dann über FET´s zu den Motoren. Leider steuern die Fet´s nicht richtigb durch. habe schon 2 verschiedene probiert (IRF520 und BUZ72a). Auch die BIP-Transistoren verstärken das PWM-Signal von den TTL´s fast garnicht. Ich arbeite mit 9V. Aus den TTL´s kommt was leicht über 4V raus. Die Transistoren hängen mit C an 9V und mit B natürlich am PWM-Signal. Sie bringen aber nur was leicht über 4V am E zusammen. Damit kann man freilich keinen FET richtig durchschalten.

    An was kann das liegen?

    Ist die Frequenz zu niedrig (ca. 5kHz).
    Wie kann ich dieses 4V-PWM-Signal auf 9V-Amplitude bringen? Muß ich da bei der Beschaltung der Transistoren vieleicht etwas beachten weils ja keine Gleichspannungsverstärkung mehr ist?

    Freue mich über jede hilfreiche Antwort.

    Sorry aber die beiden angegebenen Typen sind N-Channel Mosfets wemm ich nicht irre also nix mit C,E,und B sondern D,S,G /Draun,Source,Gate)


    Aber wie du schriebst its der Transi an 9V und Schaltet den Verbraucher der an Masse hängt.
    So kann das nicht viel werden.
    Dreh es mal um.
    Source an Masse (- Minus).
    Drain an den Verbraucher der mit seinem anderen Ende nach Vcc (+9V) geht.
    Gate an dein PWM-Signal.

    Kommste damit klar oder soll ich dir lieber ne Zeichnung kritzeln ?
    Gruß
    Ratber

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    21.10.2005
    Beiträge
    10
    Also mit C, B, E meinte ich eigentlich die BIP-Transistoren, die ich vor das Gate meiner FET´s geschaltet habe um schonmal das PWM- Signal zu verstärken, dass die FET´s richtig durchsteuern. Die Motoren hängen schon an Drain und (-) an Source. Das es andersrum nix wird ist mir klar.

    Habe auch bei den BIP-Transistoren keinen Widerstand vor dem C.
    Hab sie direkt an +9V.

    Versteh das einfach nicht, warum die FET´s nicht durchsteuern und die BIP-Transistoren das 4V PWM-Signal nicht verstärken.

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    15.10.2005
    Beiträge
    18
    Wie wärs mit nem OP amp ?
    sorry, bin nich so auf der analogen seite
    Denke nicht gedacht zu haben,
    denn das Denken der Gedanken
    ist gedankenloses Denken.

  6. #6
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.970
    Hallo Schorschi!
    Die einfache Schaltung sollte Dein Prroblem lösen. Der T1 "verstärkt" die TTL Spannung auf 9V und steuert den T2, der den Motor Schaltet. Das TTL Signal wird durch T1 invertiert, so das jetzt der Motor bei 0 ein- und bei 1 ausgeschaltet wird. Die Widerstände Rb und Rc sind nicht kritisch und können im Bereich 1k - 100k liegen.
    MfG
    Code:
                                 VCC     VCC  VCC
                                 +9V     +9V  +9V
                                  |       |    |
                                  |       |    |
                                  |     D -   / \
                                  |       ^  ( M )
                                 .-.      |   \_/
                               Rc| |      |    |
                                 | |      +----+
                                 '-'      |
                                  |    ||-+
                                  |    ||<- T2
                                  +----+|-+
                          Rb      |       |
                          ___   |/        |
              TTL >------|___|--|  T1     |
                                |<        |
                                  |       |
                                 ===     ===
                                 GND     GND

  7. #7
    Super-Moderator Lebende Robotik Legende Avatar von Manf
    Registriert seit
    30.01.2004
    Ort
    München
    Alter
    64
    Beiträge
    12.372
    Ja vielen Dank, mit Schaltbild ist es gleich deutlich.
    So muss es gehen. Beim Rb mit 10k liegt man sicher ganz gut.
    Beim Rc kommt es bei manchen Fets auf die Gateladung an, die die Schaltzeit verlangsamen kann. Da muss man dann schon oft auf 10k oder besser 1k heruntergehen.
    Manfred

  8. #8
    Neuer Benutzer Öfters hier
    Registriert seit
    21.10.2005
    Beiträge
    10
    Vielen Dank. Werd es gleich mal ausprobieren.

    Welche funktion hat die Stelle D in der Schaltung?

    MFG

  9. #9
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    11.09.2004
    Ort
    Düsseldorf
    Beiträge
    3.948
    Das ist die Löschdiode damit die Gegeninduktion des Verbrauchers dir nicht den rest der Schaltung "Grillt".

    Ist bei induktiven Verbrauchern ein "Muss"
    Gruß
    Ratber

  10. #10
    Erfahrener Benutzer Robotik Einstein Avatar von SprinterSB
    Registriert seit
    09.06.2005
    Ort
    An der Saar
    Beiträge
    2.801
    ....zudem muss der Strom weiter durch den Motor fliessen können, wenn der Transistor sperrt. Selbst wenn die Schaltung die induktiven Spannungsspitzen aushalten würde, würd es ohne Diode kaum funktionieren, weil der Strom in der off-Phase immer wieder auf 0 ginge.

    Daher kommt auch die Bezeichnung 'Freilaudiode', im Englischen auch manchmal 'diode for current recirculation'

    ::EDIT::

    soll natürlich 'Freilaufdiode' heissen...obwohl die auch schon mal lau bis warm werden
    Disclaimer: none. Sue me.

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •