-
        
+ Antworten
Ergebnis 1 bis 6 von 6

Thema: Sharp Sensoren spinnen!

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    24.01.2004
    Ort
    z.Zt. Istanbul
    Alter
    60
    Beiträge
    108

    Sharp Sensoren spinnen!

    Ich betriebe einen GP2D120; vorgesehener Bereich lt. Datenblatt 4 - 30 cm. Im selben Datenblatt kann man eine expotentiell abfallende Spannungskurve bewundern.
    So weit, so gut. Interessanterweise liefert unser Sensor, in einem Labyrith eingesetzt ab einer Entfernung von 70 cm absoluter Unsinn; die vom Prozessor angezeigten Digitalwerte liegen zwischen 30 (=0,05V, damit könnte ich leben) und 130 (=2,54V). Und das ist ...äh nicht gut.
    Kennt jemand hier dieses Problem und weiß etwa sogar woran das liegt. Es ist reproduzierbar...

    REB

  2. #2
    Gast
    So ganz versteh ich dein Problem nicht? Der Sensor kann doch nur bis 30 cm messen. Was in 70 cm Entfernung ist kann er doch garnicht erfassen

  3. #3
    Erfahrener Benutzer Roboter Genie Avatar von Michael
    Registriert seit
    17.01.2004
    Ort
    Karlstadt
    Alter
    47
    Beiträge
    1.244
    Hallo REB,
    das Problem habe ich auch, dachte schon, ich wäre der einzige
    Wie sieht der Rest der Schaltung aus? Gehst du direkt in den AD-Eingang?
    Gruss, Michael

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    29.01.2004
    Beiträge
    2.441
    So ganz versteh ich dein Problem nicht? Der Sensor kann doch nur bis 30 cm messen. Was in 70 cm Entfernung ist kann er doch garnicht erfassen
    Dass Problem dürfte sein, dass REB, bzw. seine Schaltung schlecht beurteilen kann, ob die Spannung am Sensor durch ein Hindernis innerhalb der 30 cm verursacht wird, oder ob es ein Zufallswert ist, den der Sensor ausgibt wenn er z.B. irgendwas in 70 cm Entfernung entdeckt.

    Wenn man erst nachgucken muss, ob das angezeigte Hindernis näher als 30 cm oder weiter weg ist, nutzt der Sensor nicht wirklich viel

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    24.01.2004
    Ort
    z.Zt. Istanbul
    Alter
    60
    Beiträge
    108
    Zitat Zitat von recycle
    Dass Problem dürfte sein, dass REB, bzw. seine Schaltung schlecht beurteilen kann, ob die Spannung am Sensor durch ein Hindernis innerhalb der 30 cm verursacht wird, oder ob es ein Zufallswert ist, den der Sensor ausgibt wenn er z.B. irgendwas in 70 cm Entfernung entdeckt.

    Wenn man erst nachgucken muss, ob das angezeigte Hindernis näher als 30 cm oder weiter weg ist, nutzt der Sensor nicht wirklich viel
    Ja, Du hast, wie immer, recht! Nachdem der Bot einige Male gegen eine Wand gefahren ist bzw. unlogisches Verhalten an den Tag legte (eine Wand sah, wo gar keine ist) bin ich auf diesen Trichter gekommen. Erschwerend kommt hinzu dass selbst auf 70 cm nichts ist; das nächste Hindernis befindet sich ca 1,20 m entfernt... . Wenn Wände innerhalb der Reichweite sind dann hat der Sensor kein Problem.
    Mein Verdacht ist, dass außerhalb der Reichweite die ausgegebenen Werte von der Entfernung des Jupiters zur Erde, von der Luftfeuchtigkeit (immer verdächtig!) oder gar vom Standort von Bin Laden abhängig sind. Will sagen: dass außerhalb der Reichweite irgendwelche Reflexionen oder was weiß ich den Sensort veralbern.

    @Michael: Der uC hat an den Eingängen Pullups; da kann ich nicht direkt rangehen. Zwischen dem Sensor und dem Analogport befindet sich ein OpAmp mit schwacher Verstärkung (ca. 10fach).
    Einen Elko habe ich auch schon ausprobiert; bringt aber nichts...

    Rolf (REB)

  6. #6
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    04.11.2003
    Beiträge
    136
    Hi Rolf,
    ich hatte bei mir ein ähnliches Problem. Nach längeren rumprobieren bin ich drauf gekommen das die Sensoren auf Reflexionen vom Untergrund ansprachen (Teppich). Ich hab sie jetzt so angeordnet, das sie leicht (so 5°) nach oben schauen, seitdem hab ich praktisch keine Probleme mehr.
    Gruß
    -=jens=-

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •