-
        

Ergebnis 1 bis 3 von 3

Thema: Gibt keine Kommastellen aus ?!

  1. #1
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    29.10.2004
    Ort
    GRAZ
    Alter
    51
    Beiträge
    576

    Gibt keine Kommastellen aus ?!

    Anzeige

    Hallo

    Habe da den Sharp GP2D120 jetzt so hinbekommen, dass er mir die Entfernung in cm ausgibt.

    Code:
     '--------Sharp GP2D120 Entfernungsmessung --------------------
     ' 8MHz Quarz
     ' LCD auf Port B ,
     ' +AD
    
     $regfile = "m8def.dat"
     $crystal = 8000000
    
     '---Config für LCD -----------------
    Config Lcd = 40 * 2
    Config Lcdpin = Pin , Db4 = Portb.0 , Db5 = Portb.1 , Db6 = Portb.2 , Db7 = Portb.3 , Rs = Portb.4 , E = Portb.5
    Config Lcdbus = 4
    Config Lcdmode = Port
    Cursor On
    
    
    
    '------------- config ADC -----------------------
    Config Adc = Single , Prescaler = Auto
    Config Portc = Input
    
    
    
    
    '------------------sonstiges Config -----------------
    Dim Sharp As Word
    Dim Wert As Word
    Dim Entfernung As Long
    
    Enable Interrupts
    Start Adc                               '
    
    '--------------------Hauptprogramm--------------------------
    Cls
    
    Locate 1 , 1
    Lcd "---Entfernungs messen mit Sharp GP2D120----"
    Waitms 500
    
    
    
    
    Do
    
    Wert = Getadc(0)
    Locate 2 , 1
    Lcd Wert ; "    "
    
    Entfernung = Wert - -5.692
    Entfernung = 2390 / Entfernung
    
    Locate 2 , 15
    Lcd Entfernung ; "cm  "
    
    Loop
    
    End
    Aber irgendwie gibt er mir am LCD nicht die Kommawerte mit aus ?

    Es reichen zwar die die ganzen cm auch, aber irgendwie habe ich es immer mit der Kommaausgabe/verarbeitung und würde gerne wissen, warum ich am LCD keine Nachstellen sehe .

    Kennt sich da jemand näher in Bascom aus ?

    l.G. aus Graz

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    11.09.2004
    Ort
    Düsseldorf
    Beiträge
    3.948
    Das er keine Fließkommazahlen anzeigt liegt daran das du den Datentyp für Entfernung als "Long" genommen hast.

    Single oder Double wäre hier angebracht.

    PS:

    Schau mal hier rein.
    Das neue Manual ist übersichtlicher als das mitgelieferte.
    Gruß
    Ratber

  3. #3
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    29.10.2004
    Ort
    GRAZ
    Alter
    51
    Beiträge
    576
    Hallo Ratgeber

    Danke für die Info.
    Das wars

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •