-         

Ergebnis 1 bis 6 von 6

Thema: Adapter USB auf Seriell - Problemsuche

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    10.10.2005
    Ort
    Mainz
    Beiträge
    27

    Adapter USB auf Seriell - Problemsuche

    Anzeige

    hi

    ich hab einen usb-seriell adapter an mein laptop angeschlossen um für den Asuro Roboter die programme zu übertragen.

    beim flashen folgendes phänomen:

    er findet den asuro...
    aber beim flashen der ersten page kommt eben nur " tttttttttt" .

    die COM Schnittstelle ist richtig angegeben.
    laptop sagt com 6 und oben im Flash Programm wähle ich auch com 6 aus

    habt ihr eine idee woran es liegen könnte ?
    es wäre wichtig das ich das hinbekomme.
    besten dank schon mal im vorraus.

    xyphrox

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    06.11.2004
    Beiträge
    1.693
    es wäre wichtig das ich das hinbekomme.
    Gut das du das sagst. Die meisten Probleme hier sind ja unwichtig *ironie*

    Braucht der Asuro nur Tx und Rx?

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    10.10.2005
    Ort
    Mainz
    Beiträge
    27
    öhm...
    joa also wenn du mir sagst was Tx und Rx ist kann ich dir sagen was ich davon brauche......

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    06.02.2005
    Ort
    Hamburg
    Alter
    31
    Beiträge
    4.255
    das problem wird wahrscheinlich sein, dass der infrarotadapter seine betreibsspannugna us den statusleitungen der schnittstelle "klaut", was gegen das offzielle RS232 protokoll verstößt. daher laufen die mesiten ähnlichen schaltungen nicht an solchen adaptern, weil dort die programmiersoftware die statusleitungen nicht direkt einschalten kann, um die schakltung zu versorgen.

    möglichkeiten:
    a) du kaufts dir den fertigen USB-infrarotadapter dazu
    b) du könntest es mit einem exteren netzteil am infrarotadapter versuchen...

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    20.04.2006
    Beiträge
    10
    Zitat Zitat von uwegw
    b) du könntest es mit einem exteren netzteil am infrarotadapter versuchen...
    Super Tipp - kannst du (oder wer anderes) mir noch sagen, an welche Pins des Adapters ich das Netzteil anlöten muss, ob ich Leitungen zum Rechner kappen muss, und welche Spannung ich da drauf geben muss ?

    [Nachtrag:] spricht was dagegen, sich die 5V aus der USB-Schnittstelle abzuzweigen und den USB-auf_RS232 - Adapter in Bezug auf die Spannungsversorgung quasi zu überbrücken ?

    grüsse,
    ölgötz

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    20.04.2006
    Beiträge
    10
    ich nochmal.

    ... hab's gestern abend noch ausprobiert und die 5V aus der usb-schnittstelle an pin 1 und 8 des NE555 gelötet. Die Dioden D1 bis D3 habe ich entfernt, weil die nach dem Schaltplan eh' nur dafür zuständig waren, VCC zu erzeugen. Funktioniert hat's trotzdem nicht. Hat jemand da draussen eine Idee, was ich noch ändern muss?

    Beste Grüsse vom
    ölgötz

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •