-         

Ergebnis 1 bis 3 von 3

Thema: USB-Probleme mit PIC18F2550

  1. #1
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    13.11.2004
    Ort
    München
    Alter
    30
    Beiträge
    447

    USB-Probleme mit PIC18F2550

    Anzeige

    Hallo,
    Ich habe endlich das PIC Board nachgebaut http://www.holger-klabunde.de/usb/18f2550.htm.
    Ich habe den Bootloader auf den PIC mit Brenner5.7d(abgeändert für 18F) von Sprut gebrannt und es sind keine Fehler aufgetreten.
    Wenn ich das USB Board jetzt an den PC anschliesse kommt allerdings ein kleines USB-TrayIcon in der Systemleiste.
    Wenn ich es anklicke sehe ich das Windows Fenster:"USB Device Not Recognized" in dem steht "One of the USB Devices attached to this computer has malfunctioned, and Windows does not recognize it."
    Dann stehen da meine USB Ports und ein "Unknown Device".
    Im Fenster kann man dann nur auf "Close" drücken...
    Im Hardware Manager habe ich versucht den "MCHPUSB Driver" Treiber zu installieren, der immerhin dafür vorgesehen ist, allerdings erkennt Windows nicht die Zugehörigkeit zu meinem PIC.

    Ich bin relativ Ratlos wie ich das Problem jetzt behebe.
    Mir sagen die Fehlermeldungen auch nix anderes als, als dass es nicht geht.
    Ich habe bisher nur etwas mit AVRs rumgemacht und zu PICs und USB bin ich total neu.
    Ich bin mir jetzt nicht sicher ob das Problem bei meinem Board oder bei vielleicht nur bei Windows liegt.
    Wäre nett wenn mir jemand beim Beheben der Fehler helfen könnte .
    Ich sehe übrigends gerade, dass der PIC nach ca. 5minuten am USB Port leicht warm geworden ist... ich werde da nochmal nachforschen.
    MfG Alex

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    13.11.2004
    Ort
    München
    Alter
    30
    Beiträge
    447
    Hi,
    Auch wenns keinen interressiert, aber ich habe das Problem behoben.
    Ich habe meine Geräte immer an die vorderen USB Ports angeschlossen, was nie Probleme gemacht hat - bis jetzt.
    Wenn ich den Pic hinten an ein USB Hub anschliesse, dann werden alle Treiber erkannt und es läuft auch sonst alles wie auf der Seite beschrieben.
    Es lag also tatsächlich nicht am Gerät sondern eher an Windows.
    MfG Alex

  3. #3
    Was man auch schnell mal übersieht sind die internen Pull-Up Widerstände. Heißt: Wenn man einen externen Widerstand zum Einstellen des Betriebsmodus (Low- oder Fullspeed) benutzt erkennt der PC auch kein USB Gerät

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •