-
        

Ergebnis 1 bis 6 von 6

Thema: Timer-Programmierung an Mega16

  1. #1

    Timer-Programmierung an Mega16

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo, ich beschäftige mich erst kurz mit der Assembler-Programmierung und AVR. Gestern versuchte ich, den Timer des Maga16 ein bißlein zu quälen, doch nun sind die Rollen vertauscht. Das als Anhang beigefügte Programm soll den Zähler überwachen, bis dieser 0 erreicht, der Software-Zähler wird um 1 erhöht und am LED-Port des STK500 ausgegeben. Bisher leuchtet jedoch nur LED0, ansonsten passiert nicht.
    Habt ihr einen Tip?
    Angehängte Dateien Angehängte Dateien

  2. #2
    Erfahrener Benutzer Begeisterter Techniker Avatar von H.A.R.R.Y.
    Registriert seit
    15.09.2005
    Beiträge
    306
    Hast Du es schon mal mit dem AVR-Studio debugged?
    a) Es gibt keine dummen Fragen, nur dumme Antworten
    b) Fehler macht man um aus ihnen zu lernen
    c) Jeder IO-Port kennt drei mögliche Zustände: Input, Output, Kaputt

  3. #3
    Ja, hab ich gemacht. Das Programm hab ich erst mal abgeschrieben, um einmal zu sehen, was mit Timer und Registern passiert. Dort geht jedenfalls auch nichts...

  4. #4
    Erfahrener Benutzer Begeisterter Techniker Avatar von H.A.R.R.Y.
    Registriert seit
    15.09.2005
    Beiträge
    306
    Hast Du dem Simulator beim Debuggen genau zugesehen?

    Ich weiß, das klingt jetzt von oben herunter: Am besten kapiert man, wenn man selbst den Fehler gefunden hat. Besonders dann, wenn man den Code irgendwo abgeschrieben hat.

    Deswegen: Versuche mal selbst herauszufinden, was so im einzelnen passiert und ob das Sinn macht. Falls Du es selbst dann immer noch nicht herausfindest, dann teste zum Vergleich mal diese Version:
    Angehängte Dateien Angehängte Dateien
    a) Es gibt keine dummen Fragen, nur dumme Antworten
    b) Fehler macht man um aus ihnen zu lernen
    c) Jeder IO-Port kennt drei mögliche Zustände: Input, Output, Kaputt

  5. #5
    Erfahrener Benutzer Begeisterter Techniker Avatar von H.A.R.R.Y.
    Registriert seit
    15.09.2005
    Beiträge
    306
    Nebenbei: Am STK500 wird eine LED durch log.0 (Null = LOW) am Port EINgeschaltet...
    a) Es gibt keine dummen Fragen, nur dumme Antworten
    b) Fehler macht man um aus ihnen zu lernen
    c) Jeder IO-Port kennt drei mögliche Zustände: Input, Output, Kaputt

  6. #6
    ok, ich werd erst mal selbst versuchen, den Fehler zu finden, trotzdem danke an alle... vielleicht begreif ich es mal

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •