-
        

Ergebnis 1 bis 7 von 7

Thema: problem mit terminalprogramm und ccrp5

  1. #1

    problem mit terminalprogramm und ccrp5

    Anzeige

    Hallo

    Ich habe ein Problem mit dem Terminalprogramm Hyperterminal.
    Ich habe eine Datei von der Einführung in CBASIC.
    Das Programm zeigte aber nur so komische zeichen (die es auf der Tastatur nicht gibt)
    anstatt ein paar mal "Hallo!".
    ICh habe den Sarttaster öfter gedrückt aber es kamen immer unterschiedliche zeichen.

    das ist der code (aus einer einführung)
    Code:
    'Programmtitel ausgeben
    print "C-Control/BASIC      001.BAS"
    print "============================"
    
    'Leerzeile
    print
    
    'noch ein Text
    print "Hallo!"
    
    'mehrere Ausgaben in einer Zeile
    print "Hallo!";
    print "Hallo!";
    print "Hallo!"
    
    ' zusammengefasst in einem Befehl
    print "Hallo!"; "Hallo!"; "Hallo!"
    
    ' mit Tabulatoren dazwischen
    print "Hallo!", "Hallo!", "Hallo!"
    
    ' noch eine Leerzeile ausgeben und Programmende
    print
    end
    
    ' Wenn der Starttaster jetzt noch gedrueckt ist,
    ' beginnt das Programm wieder von vorn!
    was kann ich dagegen machen?
    Liegt es an dem Code oder am Terminalprogramm?

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.06.2004
    Ort
    Aachen
    Beiträge
    2.674
    Hm, vielleicht überprüfe mal die Einstellungen. Sowas deutet auf eine falsch eingestellte Baudrate etc. hin.

  3. #3
    Zitat Zitat von RCO
    Sowas deutet auf eine falsch eingestellte Baudrate etc. hin.
    Welche ist denn die richtige?

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von Dirk
    Registriert seit
    30.04.2004
    Ort
    NRW
    Beiträge
    3.791

    Richtige RS232-Einstellung

    Welche ist denn die richtige?
    4800 8N1

    Gruß Dirk

  5. #5
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    29.01.2004
    Beiträge
    2.441
    Welche ist denn die richtige?

    4800 8N1
    Sicher? Ich habe da eigentlich 9600 in Erinnerung.
    Beim Robby CCRP5 wird eigentlich auch ein kleines Terminal-Programm mitgeliefert. Da ist die richtige Baudrate soweit ich mich erinnere fest eingestellt.

  6. #6
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    29.01.2004
    Beiträge
    2.441
    Welche ist denn die richtige?

    4800 8N1
    Sicher? Ich habe da eigentlich 9600 in Erinnerung.
    Beim Robby CCRP5 wird eigentlich auch ein kleines Terminal-Programm mitgeliefert. Da ist die richtige Baudrate soweit ich mich erinnere fest eingestellt.

  7. #7
    DANKE mit 9600 gehts

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •