-         

Ergebnis 1 bis 6 von 6

Thema: Probleme mit ATMEGA8-16PI

  1. #1

    Probleme mit ATMEGA8-16PI

    Anzeige

    Hallo,

    ich habe folgendes Problem:
    Meine Schaltung läuft mit dem ATMEGA8L-8PI ohne Probleme, auch die Schnittstelle funktioniert.
    Da ich mir beim basteln einen Port geschossen habe wollte ich mir einen neuen kaufen, aber leider bekam ich nur den ATMEGA8-16PI. Laut Datenblatt unterscheiden sie sich in der max. Möglichen Taktfrequenz. Der alte geht bis 8MHz und der neue bis 16MHz. Ich benutze einen 3,6864 MHz Quarz und ne Baudrate von 9600. Also dürfte das keine Rolle spielen, aber mein Programm bzw. Schaltung funktionieren nicht mit dem neuen Prozessor und auf dem Terminal wird nur Müll angezeigt!?

    Kann mir einer sagen was ich vielleicht noch beachten muß oder gibt es bei den beiden doch einen so großen Unterschied?

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    10.08.2004
    Ort
    Großbardorf
    Alter
    30
    Beiträge
    674
    der atmega8 läuft standartmäßig mit dem internen Oszillator bei 1 MHz
    wenn du den externen Quarz verwenden willst, musst du das in den Fusebits aktivieren

  3. #3
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    08.05.2004
    Ort
    Wilhelmshaven
    Alter
    38
    Beiträge
    324
    ah, dass habe ich gerade auch über "Elektronik" geschrieben.

  4. #4
    und wie wird der aktiviert?

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    16.06.2004
    Ort
    Bad Schussenried in Oberschwaben
    Alter
    28
    Beiträge
    1.461
    HI!

    Naja... Du nimmst deinen Programmer und programmierst damit die Fusebits.
    Wie das geht steht schon 100 mal im Forum.

    (Nicht mit den Lockbits verwechseln... )

    VLG Tobi
    http://www.tobias-schlegel.de
    "An AVR can solve (almost) every problem" - ts

  6. #6
    =D> Danke, habs gefunden. Der neue Prozessor war noch auf 1 MHz eingestellt. Jetzt funzt alles. \/

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •