-
        

Ergebnis 1 bis 6 von 6

Thema: Meine Schaltung spinnt total... Sie pfeift ohne Tonerzeuger

  1. #1
    Murus
    Gast

    Meine Schaltung spinnt total... Sie pfeift ohne Tonerzeuger

    Anzeige

    Hallo zusammen,

    ich hab momentan voll einen Durchhänger!
    Ich hab hier ne Schaltung mit nem Mega8, der einen LogicLevel-Fet per PWM ansteuert (Fet, der bei 5V GS fast voll durchschaltet) Dieser Fet steuert ein kleines 5V-1W Lämpchen.
    Ich fahre die PWM langsam per AVR hoch. Das Lämpchen beginnt auch heller zu leuchten.
    Je heller das Lämpchen leuchtet, umso deutlicher hört man ein pfeiffen (!) Was um Himmels Willen pfeift da??? Das Lämpchen??

    Und:
    Ich möchte gleichzeitig einfach nur den fliessenden Strom messen, der durch das Lämpi rauscht. Klar, ich muss die PWM glätten, nach dem Fet, falls das geht. Dann über einen Shunt messen.
    Nur: Wie glätte ich die PWM richtig? Ich hab jetzt einfach mal einen Elko parallel zum Lämpi geklemmt, doch ich krieg total wirre Zahlen auf dem LCD (die maximal möglichen Werte) Irgendwie hab ich ein totales Problem!
    Könnt ihr mir helfen?
    Wie glättet ihr eure PWMs, damit ihr per Shunt messen könnt? Ich pröbel da jetzt schon verflucht lang dran rum und hab sozusagen nix hingebracht..

    Herzliche Grüsse
    Mario

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Hallo,
    hast Du ein Oszi, mit dem Du die Signale mal visuell machen kannst ?

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    28.09.2005
    Ort
    Kiel
    Alter
    36
    Beiträge
    16
    Moin Mario!
    Das Pfeifen kommt, würd ich mal so sagen, evtl. eben durch die PWM in Zusammenspiel mit dem Kondensator oder bene auch der Lampe zustande. Mit was für eienr Frquenz betreibst du denn deine PWM? Bei einigermaßen hohen Frequ. könnte die Glühwendel der Lampe wir eine Spulenwicklung wirken und bei entsprechender Frequenz durch das ständige Auf- und Abbauen eines Spulenmagnetfeldes zum Schwingen (=Ton) angeregt werden.
    Ähnliches gilt für den Kondensator. (Denke da z.B. an diese alten Blitzgeräte)
    Wie du die PWM ordentlich glättest, kann ich dir grad leider auch nicht sagen, sorry!
    MfG, Cvecko!

  4. #4
    Murus
    Gast
    Eben leider nicht... Ich bin Schüler und habe somit keine Kohle, und Oszis sind teuer.... *heul*...
    Hmm, Frequenz der PWM... Keine Ahnung, wie find ich das raus? Ich ändere einfach laufen das Tastverhältnis (ich erhöhe es, wenn es bei 100% ist, fang ich wieder von vorne an). Ich verwende den Timer1 des Mega8 im PWM-Modus mit 8Bit. Die Frequenz der PWM ist doch immer konstant, oder? Oder war das die Periode?
    Der Kondi pfiff übrigens nicht, ich konnt ihn wegnehmen und es pfiff weiter.


    Gruss
    Mario

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    12.06.2005
    Ort
    Südwestdeutschland
    Beiträge
    1.062
    Blog-Einträge
    2
    Hallo Mario,
    Wenn Du kein Geld für ein Oszi hast, wie wäre es dann mit selberbasteln ?

    Schau mal bei:

    http://www.mikrocontroller.net/forum...oad=yes#238136

    Gruss,
    stochri

  6. #6
    Murus
    Gast
    Hehe, cool... Hab aber (noch) nicht die Möglichkeit von USART...

    Aber ich probiers jetzt mal mit RC-Gliedern. Wie berechne ich die Frequenz einer PWM?

    Gruss
    Mario

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •