-
        

Ergebnis 1 bis 10 von 10

Thema: Wie AVR-Display-Stecksatz

  1. #1
    Murus
    Gast

    Wie AVR-Display-Stecksatz

    Anzeige

    Hallo zusammen,

    momentan arbeite ich mit dem Mega8 und dem 2*20er LCD noch auf dem Steckbrett... Doch: Ich hab nur schon mit dem LCD einen riesen Kabelsalat....

    Ich hab mir gedacht, den AVR und das LCD auf eine Karte zu löten, die man dann ins Steckbrett oder in eine Schaltung stecken kann, wie beim Mainboard mit z.B. der Graka...

    Hat jemand von euch schonmal sowas gemacht? Und vorallem: Wie könnte man das machen?

    Gruss
    Mario

  2. #2
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    08.05.2004
    Ort
    Wilhelmshaven
    Alter
    38
    Beiträge
    324
    ich habe es noch nicht gemacht, aber habe das ganze auch schon geplant. Allerdings nur fürs Display. Würde dir ja die Reicheltbezeichnungen geben, aber du wirst wohl in der Schweiz nicht bei Reichelt bestellen.
    Das Problem bei der Platine wird wohl sein, dass man gerne eine einseitige Platine benutzen möchte und es schwierig sein wird auf beiden seiten eine Sockel-, bzw. Stiftleiste zu löten. Dennoch denke ich, dass es machbar sein wird.
    Werde also die zwei Stiftleisten vom Display zu "einer" Stiftleiste auf der Unterseite der Platine führen, so dass ich es ganz rechts auf dem Steckbrett anbringen kann. So spare ich mir zwar nicht so viele Reihen auf dem Steckbrett, aber der Kabelsalat hält sich in Grenzen.
    Wenn du einen extra uC als Displaytreiber benutzt dann kann du es vielleicht alles auf einer Platine unterbringen und nur die zwei Leitungen für die Kommunikation nach aussen führen. Das wäre vielleicht sinnvoll

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Hallo,
    Du kannst Dir mal das RN-Mega8 Board angucken, das hat zumidenst einen Anschluss für ein Display, das lässt sich dann aber bestimmt auf einen Platine zusammenpacken.

  4. #4
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    08.05.2004
    Ort
    Wilhelmshaven
    Alter
    38
    Beiträge
    324
    naja der Stecker hat wohl kein Rastermaß von 2,54mm. Dann muß man bei einer Steckplatine sowieso etwas basteln damit man es anschliessen kann.

  5. #5
    Murus
    Gast
    Also, ich probier jetzt mal ne Low-Price-Version:

    Ich isolier Kupferlitze (die passt ins Steckbrett) ab, löte diese als Pins an eine Lochrasterkarte, löte den AVR und das LCD auf die Karte und verbinde mit den Pins... Dann die Karte ins Experimentierboard oder in eine Buchsenleiste stecken, das Raster stimmt...

    Gruss
    Mario

  6. #6
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    08.05.2004
    Ort
    Wilhelmshaven
    Alter
    38
    Beiträge
    324
    du kriegst dein Display auf eine Lochrasterplatine gesteckt? Die haben doch ein weit kleineres Rastermaß als 2,54 oder nicht? Bei meinem ist das so.
    Falls du mit Kupferlitze dieses flexible Kabel meinst, dann kann ich dir nur empfehlen Telefonkabel zu nehmen. Die Adern sind massiv und lassen sich sehr gut ins Steckbrett stecken. Bei Litze mußt wohl vorher noch verzinnen damit es klappt. Oder machst es anders?

  7. #7
    Murus
    Gast
    Also, ich mach es so: Den 2*8er Stecker des LCDs verbinde ich fest mit dem Gehäuse des LCDs. (Gehäuse=Fassung und Logik). An meiner Steckplatine hab ich dann das Männchen des 2*8ers. Dann kann ich das LCD grad direkt da reinstecken, und es schwebt dann schön...
    Der AVR kommt auch doppelt gesockelt da drauf, ich programmiere ihn extern. Hab heute sicher über 5h an dem Zeug rumgelötet... alleine bis die Litze aufm Lochraster war und hielt... Bäh...
    Fotos werden folgen!

    Gruss
    Mario

  8. #8
    Murus
    Gast
    Bäääh, das war ja ne grauenhafte Löterei... und so sieht es auch aus... Sowäs hätte man ätzen sollen....
    Aber egal, hauptsache, der Kabelsalat wurde vom Brett verschoben... Aber es funktioniert..

    Gruss
    Mario
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken hinten_329.jpg   vorne.jpg  

  9. #9
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    08.05.2004
    Ort
    Wilhelmshaven
    Alter
    38
    Beiträge
    324
    uhh, zieht dein Display 5A oder warum hast so dickes Kabel genommen? Passt das Display überhaupt in die IC Fassung?

    Naja ich werde meins wohl die Tage ätzen. Habe ja großen Respekt vor Leuten die so Kabelsalat hinbekommen und die Funktion dennoch gegeben ist. Aber es funktioniert.

  10. #10
    Murus
    Gast
    Naa jaa, professionell ist das ja nicht, wohl eher ein Pfusch, obwohl ich 6h da dran rumgelötet habe... Ist Lötrauch eigentlich stark gesundheitsschädlich? Sonst muss ich mal nen PC-Lüfter zur Absauganlage umfunktionieren...


    Ich hatte kein dünneres Kabel.. und ätzen kann ich auch net...
    Das Display kommt von vorne gesehen oben links und von hinten gesehen oben rechts in die Steckerleiste, in die IC-Fassung kommt der AVR.
    Dann werde ich die Pins noch anschreiben, damit ich weiss, wo was ist. Zusätzlich pack ich das noch in Heissleim ein, sonst is dat ein wenig labil (ausser die Lötpunkte, falls mal eine kalt wird).
    Aber sonst bin ich recht zufrieden, ausser, dass ich nen Hammer brauch, damit es ins Steckbrett geht (die selbergemachten Pins sind halt nicht so schön und etwas dick) Hauptsache es geht, ich lass das da drin ja eh ne Weile stecken.
    Das mit dem Display funktioniert auch, hab den Displaystecker mit Sekundenkleber an dessen Gehäuse geklebt, jetzt funktioniert das perfekt.
    Ein zweites LM317 Netzteil hab ich auch noch gebaut, (auf dem Bild von Vorne im Hintergrund) hab jetzt zwei Netzteile und kann mal richtig loslegen. (eines für die 5V des AVR und das andere für Anderes, eines hätte aber auch gereicht (ein 7805er für den AVR und den "Rest" des Netzteils für den Rest.)

    Greets
    Mario

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •