-         

Ergebnis 1 bis 2 von 2

Thema: problem mit avrdude

  1. #1

    problem mit avrdude

    Anzeige

    Hi ich bin gerade dabei meine ersten schritte zu machen.
    habe es geschafft mit winavr des mitgelieferte beispiele zu übersetzten:

    > "make.exe" all

    -------- begin --------
    avr-gcc (GCC) 3.4.3
    Copyright (C) 2004 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


    Compiling: lcd_test.c
    avr-gcc -c -mmcu=atmega32 -I. -gstabs -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -Wall -Wstrict-prototypes -Wa,-adhlns=lcd_test.lst -std=gnu99 -Wp,-M,-MP,-MT,lcd_test.o,-MF,.dep/lcd_test.o.d lcd_test.c -o lcd_test.o

    Linking: lcd_test.elf
    avr-gcc -mmcu=atmega32 -I. -gstabs -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -Wall -Wstrict-prototypes -Wa,-adhlns=lcd_test.o -std=gnu99 -Wp,-M,-MP,-MT,lcd_test.o,-MF,.dep/lcd_test.elf.d lcd_test.o --output lcd_test.elf -Wl,-Map=lcd_test.map,--cref -lm

    Creating load file for Flash: lcd_test.hex
    avr-objcopy -O ihex -R .eeprom lcd_test.elf lcd_test.hex

    Creating load file for EEPROM: lcd_test.eep
    avr-objcopy -j .eeprom --set-section-flags=.eeprom="alloc,load" \
    --change-section-lma .eeprom=0 -O ihex lcd_test.elf lcd_test.eep

    Creating Extended Listing: lcd_test.lss
    avr-objdump -h -S lcd_test.elf > lcd_test.lss

    Creating Symbol Table: lcd_test.sym
    avr-nm -n lcd_test.elf > lcd_test.sym

    Size after:
    lcd_test.elf :
    section size addr
    .text 750 0
    .data 84 8388704
    .bss 0 8388788
    .noinit 0 8388788
    .eeprom 0 8454144
    .stab 3300 0
    .stabstr 2450 0
    Total 6584



    Errors: none
    -------- end --------


    > Process Exit Code: 0

    wenn ich jetzt aber WINAVR Programm sage kommt folgendes:

    > "make.exe" program
    avrdude -p atmega32 -P lpt1 -c stk200 -U flash:w:lcd_test.hex
    avrdude: can't open device "giveio"

    avrdude: failed to open parallel port "lpt1"

    make.exe: *** [program] Error 1

    > Process Exit Code: 2


    Ich habe Windows XP,
    den STK200 Parl. adapter
    und einen Atmel Atmega32L mit 16 MHz Quarz.

    Kann mir jemand helfen und erklären wies geht?

    Vielen Dank jetzt schonmal!

  2. #2
    fehler gefunden:

    Windows NT/2K/XP

    On Windows NT, 2000, and XP user applications cannot directly access the parallel port. However, kernel mode drivers can access the parallel port. giveio.sys is a driver that can allow user applications to set the state of the parallel port pins.

    Before using AVRDUDE, the giveio.sys driver must be loaded. The accompanying command-line program, loaddrv.exe, can do just that.

    To make things even easier there are 3 batch files that are also included:

    1. install_giveio.bat Install and start the giveio driver.
    2. status_giveio.bat Check on the status of the giveio driver.
    3. remove_giveio.bat Stop and remove the giveio driver from memory.

    These 3 batch files calls the loaddrv program with various options to install, start, stop, and remove the driver.

    When you first execute install_giveio.bat, loaddrv.exe and giveio.sys must be in the current directory. When install_giveio.bat is executed it will copy giveio.sys from your current directory to your Windows directory. It will then load the driver from the Windows directory. This means that after the first time install_giveio is executed, you should be able to subsequently execute the batch file from any directory and have it successfully start the driver.

    Note that you must have administrator privilege to load the giveio driver.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •