-         

Ergebnis 1 bis 7 von 7

Thema: EA DIP204-4

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    07.02.2005
    Beiträge
    11

    EA DIP204-4

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hi @ all,

    Ich habe ein Problem mein Display in den 4 Zeilen Modus zu bekommen.
    Ich benutze das EA DIP204-4 Display im 4 bit Modus.

    Laut der Beschreibung
    ( http://www.avrcard.com/Documents/dat...s/dip204-4.pdf )

    sollte ich mit dem senden von,

    DB3 DB2 DB1 DB0 RS RW RE-Bit
    1 1 0 1 0 0 1

    in den 4 Zeilen Modus gelangen.

    - Entspricht das RE-Bit dem Pin E(SCLK) ?
    - Wenn nicht wie setzt ich das RE Bit?
    - Kann in den 4 Zeilen Modus nur wärend der Initialisierung
    gelangt werden oder auch noch danch, wie man z.b auch noch den
    Cursor nach der Initialisierung bilkend einstellen kann?

    ich komm an diesem Punkt leider nicht mehr weiter.
    Für jeden Tip wäre ich dankbar!

    Das Display benutzt den Controller: KS0073 -->

    http://www.electronic-engineering.ch...lcd/ks0073.pdf

    Danke schonmal

  2. #2
    Hallo
    hättest Du die Antwort lieber im Forum Elektronik, oder lieber im Forum Atmel AVR Controller [-X

    Hast Du Dir schon den Thread
    http://www.roboternetz.de/phpBB2/zei...ghlight=dip204
    angeschaut ? Hilft Dir das weiter ?

    Gruss
    Frank

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    07.02.2005
    Beiträge
    11
    Hi,

    sorry, ich mach nur schon so ewig mit dem sch*** 4 Zeilen Modus rum!

    Hilft mir nicht so sehr weiter.
    Trotzdem Danke mal
    Das Display funktioniert soweit einwandfrei.

    So habe ich alle Kombinationsmöglichkeiten durchgetestet um in den 4 zeilen modus zu gelangen ( 1101<-- für die Datenbits| mit SBI habe ich jetzt alle Kombinationen der restlichen Leitungen RW etc. durchgetestet, vergebens) :

    Code:
              ldi temp1,0b00001101
    	   out PORTD,temp1
    
               sbi PORTD, 4                 
               sbi PORTD, 5
               sbi PORTD, 6
               nop                          
               nop
               nop
               nop
               nop
               nop
     
        LDI ZH,HIGH(60000)          
        LDI ZL,LOW(60000)           
    ZAEL1:
        SBIW ZL,1                   
        BRNE ZAEL1
    
    
               nop                          
               nop
               nop
               nop
               nop
               nop
               cbi PORTD, 4                 
               cbi PORTD, 5
               cbi PORTD, 6

    Mit der extrem langen Wareschleife, will ich nur sicher gehen, daß das auch mit dem Timing 100%ig ist.

    Gruß

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    07.02.2005
    Beiträge
    11
    Problem gelöst!

    Das RE-Bit wird mit dem Befehl - "Function Set" gesetzt.

    Alle vier Zeilen funktionieren wunderbar.
    Gruß und Danke

  5. #5
    Zitat Zitat von Eric79
    Problem gelöst!
    Alle vier Zeilen funktionieren wunderbar.
    Hallo,

    Anscheinend haben hier einige Leute Probleme mit diesem Display.
    Hättest Du nicht Lust Deine Routinen hier zu veröffentlichen, damit wir alle davon lernen und davon nutznießen können ?

    Ich habe dieses Display immer im seriellen Betrieb angeschlossen ( spart Leitungen und Ports ).
    Die Routine dafür gibt es :
    http://www.roboternetz.de/phpBB2/zei...ghlight=dip204
    http://www.tklinux.de/electronic.html

    Gruss
    Frank

  6. #6
    Hi Zusammen,

    könnte jemand von euch eine Source in Basic++ bereitstellen, mit der ich ein solches Display (4x20 mit KS0073) richtig initialisieren kann und alle 4 Zeilen richtig funktionieren. Ich hab die gleichen Probleme, kriegs aber nicht hin! Wäre euch echt dankbar

    Gruß

    Jusaro

  7. #7
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    08.05.2004
    Ort
    Wilhelmshaven
    Alter
    38
    Beiträge
    324
    oder in Assembler. Für Basic gibts das glaube ich schon. Mal im Forum suchen. Habe ich bei meiner Suche mal gefunden.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •