-         

+ Antworten
Ergebnis 1 bis 2 von 2

Thema: Visual Basic zu AVR (ATmega16) Verbindung

  1. #1
    Hendrixxx
    Gast

    Visual Basic zu AVR (ATmega16) Verbindung

    Anzeige


    Hallo!

    Ich habe eine Frage bezüglich zum Empfangen und Senden von Daten in Visual Basic. Ich versteh all die Funktionen und auch auf der Mikrocontrollerseite funktioniert alles, jedoch bekomm ich immer seltsame Werte in den COM Port (Visual Basic) bzw. keine wenn ich sie in Visual Basic sende und im Controller ausgeben will.

    Braucht dies irgendeine bestimmte Codierung oder Umwandlung (ASC, VAR, schon probiert funktionieren nicht) um zu funktionieren. Wäre sehr dankbar für eure Hilfe.

    Vermutlich muss ich die Werte die ich in Visual Basic empfangen (meistens komische ASCI Zeichen, die niemand versteht) irgendwie umwandeln, jedoch haut das nicht hin (auch mit ASC() nicht).

    mfg hendrixxx

  2. #2
    Gast
    Vermutlich muss ich die Werte die ich in Visual Basic empfangen (meistens komische ASCI Zeichen, die niemand versteht) irgendwie umwandeln
    Hast du mal in deinem VB Programm geprüft ob die Einstellungen für den COM-Port, hauptsächlich die Übertragungsgeschwindigkeit stimmt?
    Daran könnte es auch liegen, dass nur Zeichensalat ankommt.

+ Antworten

Benutzer, die dieses Thema gelesen haben: 0

Derzeit gibt es keine Benutzer zum Anzeigen.

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •