-

Antworten

Thema: PROTOBED StepM – TMC222 RN

Nachricht

Klicke hier, um dich anzumelden

Wie nennt man die Sinnesorgane eines Roboters (Mehrzahl)? S...

 

Du kannst aus dieser Liste ein Symbol für deine Nachricht auswählen.

Zusätzliche Einstellungen

  • Links werden automatisch in BB-Code umgewandelt, z.B. www.beispiel.de in [URL]http://www.beispiel.de[/URL].

Übersicht (Neuester Beitrag zuerst)

  • 30.11.2008, 14:48
    hauschka
    Die Software.doc Datei ist beschädigt.

    Oder kann man die mit Microsoft Word nicht öffnen?

    LG
  • 29.11.2008, 14:37
    darwin.nuernberg
    Zitat Zitat von hauschka
    Hallo!

    Kannst du den Download2 noch mal ins Forum stellen? Die Datei scheint beschädigt zu sein.

    LG
    Ist doch alles i.O. (29.11.200
    Download / entpacken geprüft
  • 08.10.2008, 19:43
    hauschka
    Hallo!

    Kannst du den Download2 noch mal ins Forum stellen? Die Datei scheint beschädigt zu sein.

    LG
  • 07.06.2008, 15:08
    darwin.nuernberg
    Zitat Zitat von matsch
    Hallo

    Erstmal möchte ich dir für deinen guten TMC222 Beitrag danken. Ist wirklich eine große Hilfe.

    Ich habe eine Frage zum TMC222. Und zwar zum RunInit Befehl. Hast du den Befehl schon einemal benutzt?
    Ich habe da ein Verständnisproblem. Wenn ich den TMC222 in Betrieb nehme weiß der Treiber nicht wo der Motor steht. Ich möchte nun den RunInit Befehl zum Finden der Referenz benutzen. Doch woher erhält der Motortreiber die Rückmeldung, dass der Endanschlag (Gabellichtschranke oder so..) erreicht wurde? Erst dann wird doch die kleine Rückbewegung ausgeführt und anschliessend der Zähler resettet.
    Auch seltsam ist, dass ich ja nicht sagen kann was die erste Zielposition ist. Ich weiß ja nicht wo der Motor tatsächlich steht.

    Hoffe du kannst noch folgen

    Vielelicht ist es das einfachste, wenn ich mir eine eigene Init Routine erstelle.

    Danke Dir
    MAtthias
    Ich habe schon länger garnichts mehr gemacht (keine Zeit mmt.), auch nicht mit dem TMC222.

    Eine Referenz ist gegeben wenn der SWI-Pin Hi oder LOW geschaltet wird (ist egal) wenn der Pin offen ist dann ist keine Referenz gegeben.

    also [SWI-HI] / [SWI-LOW] oder [SWI-OFFEN]

    JA ist so! (ich hab mich auch gewundert).

    Ob und wie der TMC die Referenzposition anfährt, habe ich weder geprprüft noch weiter nachgeforscht. Da musst Du wohl mal im TMC-Forum nachfragen.

    Außerdem sollte man ja acuh definieren können, in welche Richtung der >Motor dreht wenn die referenz gesucht werden soll (könnte hier das SHAFT-Bit ausschlaggebend sein?)
  • 08.10.2007, 19:13
    Sefiroth
    Hallo Darwin!

    Eine echt gute Arbeit, die Du da geleistet hast. Hätte ich es früher gefunden, wäre mir so einiges an Schwierigkeiten mit dem TMC222 erspart geblieben

    Ich setze den TMC222 gerade ein, um eine Tachonadel zu bewegen. Leider gibt es dabei Schwierigkeiten... Die Nadel bewegt sich nur zuckend, vibrierend und ruckelnd - also alles andere als gleichmäßig. Im Trinamic Forum sind wir dann darauf gekommen, dass es wahrscheinlich am Nennstrom meines Schrittmotors liegt. Der hat nämlich mit 144 Ohm und 5V Nennspannung einen Nennstrom von 35 mA - der TMC222 kann aber minimal nur auf 59mA eingestellt werden...

    Hast Du da vielleicht einen Rat was ich machen kann? Wäre schade, wenn ich die Hardware jetzt umsonst besorgt und aufgebaut habe

    Btw, in Deiner Beschreibung steht auf Seite 36, dass bei Irun,hold = 0 der größte Strom fließt, bei 15 der kleinste. So wie ich das verstanden habe ist es genau andersrum. Oder arbeiten die beim TMC222 auch noch mit invertierten Bitfolgen oder ähnlichem Quatsch?

    Gruß, André
  • 04.11.2006, 09:26
    darwin.nuernberg
    Zitat Zitat von starkeeper
    Bei meiner Schaltung die ich dem Datenblatt entnommen habe, stellt sich das Problem, das meine 5V Spannung manchmal einbricht, wenn ich dem TMC222 einen Befehl sende, sodass mein uC neustartet. Und das wo der TMC ja garkeine 5V verwendet sondern bei mir mit 12V aus einem 4A Netzteil versorgt wird! Könnt ihr mir da weiterhelfen?

    Gruß starkeeper
    Eindeutiger Hinweis, dass Dein Netzteil nicht iordnungsgemäß funktioniert oder zu wenig Leistung hat.

    Probier mal ein größeres Netzteil

    Der angesprohene Kondensator ist nötig um solche Spannungseinbüche zu kompensieren, ich hatte hiermit keine Probleme, da mein Netzteil (auf meinem Protobed ATmeg V5) bereits entsprechende Ladekondensatoren aufweist (I2C bzw. CPU Seite)

    Die Versorgung der Motoren muss sowiso seperat erfolgen da diese jenseits dessen liegen was die CPU verkraftet (midestens 8V müssen es sein, sonst funktiniert die Schaltung erst garnicht -> siehe Datenblatt)
  • 01.11.2006, 11:19
    starkeeper
    Hi,
    ich habe eine Platine mit zwei der TMC222 bestückt. Nun habe ich ein paar Probleme mit der Spannungsversorgung meiner Platine. Bei der Lösungssuche bin ich auf die Schaltung hier gestossen. Was mir gleich auffällt, dass der 100uF aus der Referenzschaltung im Datenblatt, bei euch verschwunden ist. Was hat der Kondensator verbrochen?

    Bei meiner Schaltung die ich dem Datenblatt entnommen habe, stellt sich das Problem, das meine 5V Spannung manchmal einbricht, wenn ich dem TMC222 einen Befehl sende, sodass mein uC neustartet. Und das wo der TMC ja garkeine 5V verwendet sondern bei mir mit 12V aus einem 4A Netzteil versorgt wird! Könnt ihr mir da weiterhelfen?

    Gruß starkeeper
  • 11.08.2006, 10:19
    darwin.nuernberg
    Ja, es passt rein,
    der AVR ist aber schon ganz schön voll (es geht aber noch etwas mehr).

    Klar könnte man auch schlanker programmieren,
    aber dann hat man die Oberfläche nicht mehr im AVR sondern müsste ein externes Prog. schreiben.

    So ist man Plattformunabhängig. Ein Terminalprogramm reicht aus.

    Sicherlich ginge es bestimmt noch etwas einfacher, ich habs halt so gelöst...

    PS
    neue Info aus den "Application Notes" :der SWI hat den einen Status (1) bei LOW (GND) oder HI (VCC) und den anderen Status (0) bei OPEN! (also ohne Jumper).
Dieses Thema enthält mehr als 8 Antworten. Klicke hier, um das ganze Thema zu lesen.

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •